View Source hangs if a paragraph has more than 1261 characters (and includes spaces)

RESOLVED WORKSFORME

Status

Core Graveyard
View Source
--
critical
RESOLVED WORKSFORME
15 years ago
7 years ago

People

(Reporter: Jens Kager, Assigned: Doron Rosenberg (IBM))

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Mozilla 1.3a hangs (mostly, sometimes it crashes) when viewing the source of a
HTML file which has a paragraph with more than 1261 characters in it.
Interestingly, if the paragraph contains no spaces, this doesn't happen, it has
to have at least one space in it. The HTML is rendered ok, though.

Reproducible: Always

Steps to Reproduce:
1. Load the site
2. View Source
(Reporter)

Comment 1

15 years ago
Created attachment 113638 [details]
1261 characters, including one space

When replacing the space inside this file with another x, everything is fine.
(Reporter)

Comment 2

15 years ago
Created attachment 113640 [details]
1260 characters (including one space)

This doesn't crash for me.
worksforme, linux trunk build 2003-02-04-08

Comment 4

15 years ago
WORKSFORME - CVS Build from approx 2/3/03 on Windows XP Home

Reporter:  Please try this with a more recent build (like one of the nightlies)

Comment 5

15 years ago
worksforme with linux trunk 20030204 and 1.3a
Keywords: hang

Comment 6

15 years ago
Critical.
Severity: normal → critical
(Reporter)

Comment 7

15 years ago
Indeed, I don't see this problem any more with 1.3b.

Comment 8

15 years ago
This problem occurs for me on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3)
Gecko/20030313.  When I click on the attachment, then View->Source, I get a crash. 

Also, I get a hang when I View->Source on just about any web page.  I scroll
down the page for a bit, then it hangs.

Comment 9

15 years ago
To clarify, the crash occurs with the 1261 char attachment, but not the 1260
char attachment.

Comment 10

15 years ago
Is this related to Bug 193402?

Comment 11

14 years ago
 * WFM (1.6)
 * Original reporter says the problem isn't present in 1.3b
 * Additional commenter experiencing the problem (Gus Scheidt) doesn't appear to
be CC'd

-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey

Updated

7 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.