overflow: scroll in conjunction with border-collapse: collapse - results in border lines not scrolling with content

RESOLVED DUPLICATE of bug 135236

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 135236
15 years ago
15 years ago

People

(Reporter: Andy Koch, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

a table with thead, tbody, and tfoot. the table has border-collapse: collapse
specified. the tbody has overflow: scroll specified. the tbody contains 12 table
rows, each 60px high and are numbered: <tr><td>1</td></tr>, <tr><td>2</td></tr>
...  you scroll and the numbers move, the borders for each tr/td do no scroll
with the content. change table to border-collapse: separate and things work as
they should, that is the borders scroll with the content. see url

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Dup of "Cell borders do not scroll in scrolling tbody with border-collapse:collapse"

*** This bug has been marked as a duplicate of 135236 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.