reproducable crash when I try to drag and drop a bookmark from a folder on personal toolbar to the personal toolbar [@ nsMenuPopupFrame::SetCurrentMenuItem ]

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: jag (Peter Annema))

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

jag, this might be a dup of one of the bugs you are working on for 1.3 beta.

reproducable crash when I try to drag and drop from folder on personal toolbar

on my personal toolbar, among other things, I have a folder with a bunch of 
bookmarks.  if I open the folder on the personal toolbar by clicking on it, and 
then I select one of the bookmarks and drag it to my personal toolbar, the drop 
appears to succeed, but the folder stays open for a second, and then I crash.

here's the stack:

nsMenuPopupFrame::SetCurrentMenuItem(nsMenuPopupFrame * const 0x049a6a50, 
nsIMenuFrame * 0x00000000) line 1577 + 19 bytes
nsMenuFrame::OpenMenuInternal(int 0) line 899
nsMenuFrame::AttributeChanged(nsMenuFrame * const 0x036e6efc, nsIPresContext * 
0x02de0be0, nsIContent * 0x036b3688, int 0, nsIAtom * 0x00fead00, int 3, int 
126) line 718
nsCSSFrameConstructor::AttributeChanged(nsCSSFrameConstructor * const 
0x02e275c8, nsIPresContext * 0x02de0be0, nsIContent * 0x036b3688, int 0, 
nsIAtom * 0x00fead00, int 3, nsChangeHint 14) line 10818 + 36 bytes
StyleSetImpl::AttributeChanged(StyleSetImpl * const 0x02e27300, nsIPresContext 
* 0x02de0be0, nsIContent * 0x036b3688, int 0, nsIAtom * 0x00fead00, int 3, 
nsChangeHint nsChangeHint_Unknown) line 1645
PresShell::AttributeChanged(PresShell * const 0x02e276f8, nsIDocument * 
0x02d9eef8, nsIContent * 0x036b3688, int 0, nsIAtom * 0x00fead00, int 3, 
nsChangeHint nsChangeHint_Unknown) line 5159 + 61 bytes
nsXULDocument::AttributeChanged(nsXULDocument * const 0x02d9eef8, nsIContent * 
0x036b3688, int 0, nsIAtom * 0x00fead00, int 3, nsChangeHint 
nsChangeHint_Unknown) line 2158
nsXULElement::UnsetAttr(nsXULElement * const 0x036b3688, int 0, nsIAtom * 
0x00fead00, int 1) line 2897
nsXULElement::RemoveAttribute(nsXULElement * const 0x036b368c, const nsAString 
& {...}) line 1328 + 31 bytes
nsMenuFrame::OpenMenu(nsMenuFrame * const 0x036e6f84, int 0) line 751 + 42 bytes
nsMenuPopupFrame::DismissChain(nsMenuPopupFrame * const 0x049a6a50) line 2059
nsMenuDismissalListener::Rollup(nsMenuDismissalListener * const 0x054b1af8) 
line 115
nsWindow::DealWithPopups(unsigned int 161, unsigned int 2, long 393983, long * 
0x0012fc40) line 1339
nsWindow::WindowProc(HWND__ * 0x000a021c, unsigned int 161, unsigned int 2, 
long 393983) line 1367 + 21 bytes
USER32! 77e3a290()
USER32! 77e145b1()
USER32! 77e1a752()
nsAppShellService::Run(nsAppShellService * const 0x015acae0) line 480
main1(int 2, char * * 0x00270060, nsISupports * 0x00f16bd8) line 1273 + 32 bytes
main(int 2, char * * 0x00270060) line 1636 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e9ca90()

mCurrentMenu points to memory that has already been deleted.
I can send you my bookmarks.html file (privately) if you want to try it out.

Comment 2

15 years ago
related: bug 158428 ? The stack is different though.
Severity: normal → critical
Keywords: crash
Summary: reproducable crash when I try to drag and drop from folder on personal toolbar → reproducable crash when I try to drag and drop from folder on personal toolbar [@ nsMenuPopupFrame::SetCurrentMenuItem ]
Summary: reproducable crash when I try to drag and drop from folder on personal toolbar [@ nsMenuPopupFrame::SetCurrentMenuItem ] → reproducable crash when I try to drag and drop a bookmark from a folder on personal toolbar to the personal toolbar [@ nsMenuPopupFrame::SetCurrentMenuItem ]
I'm rebuilding my tree, to make sure this wasn't something fixed in the past 
two days.

it sounded like a 1.3 beta blocker bug that jag and/or dbaron was investigating.
ok, after pulling and rebuilding I can still reproduce this.

when I drag the bookmark from the personal toolbar folder to the personal 
toolbar, and drop it, the personal toolbar folder stays open.  

I just wait a second (the folder is still open) and then it crashes.
Keywords: nsbeta1
Could this be caused be the patch on bug 187839?
I tried to reproduce, but the bookmarks within the folders on my personal
toolbar aren't draggable.  (Maybe that's a Linux/Windows difference due to
previous crashes on Linux?)

Comment 7

15 years ago
WFM Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030206
1.032 KB bookmarks.html, more than 17 folders visible on toolbar.
Dragged bookmark from folder to toolbar, folder closed before I even was on the
toolbar. After releasing link on toolbar, I deleted it, or dragged it back, or
opened it in new tab, and then deleted it, restored by dragging from location
bar of new tab to different folder.
Win98 with SP1, 96 MB RAM.

Comment 8

15 years ago
WFM, current build Win2k.
Actually, I do this all the time without problems.
Can anybody still reproduce?

David Baron, that difference is bug 151336.

Comment 9

15 years ago
I'm getting this with 1.4 beta:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

Comment 10

15 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 11

15 years ago
Also getting this with 1.4 beta in Win XP. Only 11 bookmarks on the toolbar.

Comment 12

15 years ago
WFM build 2003051708, Windows 2000

Comment 13

15 years ago
I'm not sure if this is the same thing (I think so), but 1.4b build 20030507
on XP crashes for me when I drag from the personal toolbar /to/ the Bookmarks 
dropdown. (It doesn't wait a second first, though, it just dies.)

Comment 14

15 years ago
Same here now, with build 2003061508 Win2k I crash when dragging several links
to the personal toolbar folder in the bookmark manager.

Comment 15

15 years ago
Like comment #14, I also repeatably see that drag & drop transfer of a selection
of multiple bookmarks causes a crash of Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.5a) Gecko/20030617 on a Windows 2000 machine.  Crash is
reproducible.  

Comment 16

15 years ago
This happends every time you want to migrate an old profile to a new clean
installation. Setting blocking 1.4 flag to ?.
Flags: blocking1.4?

Comment 17

15 years ago
With build 2003061908 Windows 2000 it seems like this is not reproducible
anymore? Can anyone verify this?

Comment 18

15 years ago
mozilla1.4 shipped. unsetting blocking1.4 request.
Flags: blocking1.4?

Comment 19

15 years ago
I got similar symptoms, when dragging and dropping a bookmark from one toolbar
folder to another one. I've installed Mozilla 1.5 Build ID 2003082604 on a Win2k
system. The bug persists on my system since Ver 1.3. I'm getting a 100% CPU
usage situation, no total crash.

Comment 20

14 years ago
WFM with Moz 1.7a build 2004021508 Win NT 4.0

IMHO old bug, old versions ... Is this bug still valid? (see comment 17).

Comment 21

14 years ago
This seems to have been fixed somehow:
never reported since 1.5 and WFM by several people, including at least one who
could reproduce it earlier.
However, please reopen, if this returns or is still reproducable under certain
circumstances.
-> WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
Crash Signature: [@ nsMenuPopupFrame::SetCurrentMenuItem ]
You need to log in before you can comment on or make changes to this bug.