phoenix stops responding to keyboard events

VERIFIED INVALID

Status

()

Firefox
General
VERIFIED INVALID
15 years ago
14 years ago

People

(Reporter: paulv, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

Sometimes Phoenix stops responding to keyboard events(arrow keys, alt-f, etc)
completely. Additionally, I can't click in any text entry boxes (the blinking
cursor never appears). The mouse continues to function normally, however. The
only workaround I've found is clicking Help->About and clicking ok. It also
seems to happen more frequently when I middle click to open a link in a new tab,
however it happens other times as well.

I am occasionally able to reproduce this bug, but it seems not to happen as
often when I'm trying to get it to happen, if that makes sense. 

This happens with a fresh install of Phoenix 0.5.

Reproducible: Sometimes

Steps to Reproduce:
1. Go to http://bugzilla.mozilla.org/
2. Click on Query Page
3. Let the page finish loading and try using the keyboard

Actual Results:  
The keyboard stops responding

Expected Results:  
The keyboard should respond.

Comment 1

15 years ago
WFM using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b)
Gecko/20030207 Phoenix/0.5
Reporter, could you please test with a new profile (more info here:
http://texturizer.net/phoenix/bugs.html )and the latest nightly build?
(Reporter)

Comment 2

15 years ago
I tried with a new profile and the 20030207 build and I was able to reproduce
the problem.

paulv

Comment 3

15 years ago
WFM Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211 Phoenix/0.5

But this is still likely to be Linux-only related to some problem with X. What
distribution are you using and what X version? Have you seen this bug on a
computer other than your own?


Seb, just put me on the CC list when you come across bugs that are likely
Linux-only :)
(Reporter)

Comment 4

15 years ago
I'm using Debian 3.0(woody) with security updates. The version of X is 4.1.0-16.
I have not experienced this with any other application I run, and even while
phoenix doesn't respond to keyboard events, other programs work fine.

This computer is the only computer I have real access to (and any of the other
machines I could arrange to get access to are running Debian Woody as well). I
have   anecdotal evidence of this happening on other people's machines. I will
try to confirm this.

paulv

Comment 5

15 years ago
I'm running Debian Sarge (upgraded from a Woody install) with some packages from
Sid and I can't say that I've ever seen what you're seeing. Maybe your computer
is a little short on memory and it's causing a slight freeze-up or delay? It's
just that if we can't duplicate it the devs are going to have some trouble
fixing it.


André,
Have you seen this bug at all?
(Reporter)

Comment 6

15 years ago
Some of the testing I've done is right after a reboot running twm, so I suspect
that this isn't a memory issue. It does seem that focusing a new window(either
the about box or an xterm that is sitting behind it) and then refocusing Phoenix
fixes the problem.

I was able to see briefly with strace that phoenix was making system
calls(reads, writes, ioctls, etc. unfortunately, I dont have the log) as I was
pressing keys that phoenix didn't otherwise respond to. I'm not entirely sure if
this helps at all.

If there is some other debugging(attaching gdb? ltrace? building with debugging
enabled?) I would be willing to try that. I would be willing to look at the code
myself(if I can find the time and someone is willing to point me in the right
direction), too, and try to figure out what is going on.

paulv
(Reporter)

Comment 7

15 years ago
This appears to be a very, very strange window manager bug. Sorry for wasting
everyone's time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 8

14 years ago
verified invalid 2004-01-10
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.