relative positioned div transparently covers floated link, making it unclickable

VERIFIED DUPLICATE of bug 102695

Status

()

Core
Layout: Floats
--
minor
VERIFIED DUPLICATE of bug 102695
15 years ago
14 years ago

People

(Reporter: Carl Meyer, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830
Build Identifier: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

In the (validating) page at http://mennonot2.goshen.edu/~carljm/float-bug.html

The relatively-positioned div will invisibly "cover" the links in the floated
span and render them unclickable (or portions of them depending on the sizes of
the images involved).  This happens regardless of whether the links are
contained within a floated span or div, or whether the <a> tags themselves, or
the <img> tags, are floated.

This only seems to be a problem if the div is relatively positioned - if it is
floated or positioned statically or absolutely the problem disappears.

I would think that these floated links should remain clickable even in the
presence of a relatively positioned div.

Reproducible: Always

Steps to Reproduce:
1.  Visit the above page, or create any page with floated links next to a
relatively positioned div containing an opposite-floated image.
2. Try to click on the floated links.

Actual Results:  
The floated links are not clickable (or at least the portion of them "covered"
by the relatively positioned div is not clickable).

Expected Results:  
I believe those links should still be clickable, though I could be wrong.

Comment 1

15 years ago
I think it is dupe of bug 102695.
(Reporter)

Comment 2

15 years ago
I concur.  Sorry, didn't use the right search terms to find that one.  I can see
that the "proper behavior" on this one is a bit controversial, with good reason.

*** This bug has been marked as a duplicate of 102695 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.