naturalvoices.att.com - dropdown menu is not updated properly when changing it dynamically using javascript

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: A. Lee, Unassigned)

Tracking

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Build: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.3b) Gecko/20030205
Build ID: 2003020508

Steps to reproduce:
1) Goto http://www.naturalvoices.att.com/demos/, or the attachment
originalfile.html.
2) select a language in the 'select a language' dropdown menu

Expected Result: the 'select a voice' dropdown menu should have a list of names
for the chosen language.

Actual Result: sometimes the 'select a voice' dropdown menu is empty, sometimes
it only has the '-- select a voice --' item, depending on the language chosen.


P.S.: I initially mark this bug as Tech Evangelism, but I'm not too sure about
this, because:

1) I made a little test file <attachment dropdownmenutest.html>. The javascript
code to change the dropdown menu and listbox seems to work fine. So looks like
mozilla is not the cause.

2) However, if I turn the "-- select a voice --" dropdown menu into a list, by
adding the parameter 'size="5"' to line 815 <attachment modifiedfile.html> (no
other code is changed), the page works. IMO, if it's only the page's problem, it
should affect both the dropdown menu and the list.

3) If I add </font> to line 802 or line 812 of <attachment originalfile.html>,
problem seems to go away. If I add </font> to line 819, problem still occur, and
I can't understand this behaviour.
(Reporter)

Comment 1

16 years ago
Created attachment 113782 [details]
Original Source Code at http://www.naturalvoices.att.com/demos/
(Reporter)

Comment 2

16 years ago
Created attachment 113783 [details]
Same page as originalfile.html, using a listbox instead of dropdown menu
(Reporter)

Comment 3

16 years ago
Created attachment 113784 [details]
Test file for dynamically changing dropdown menu and listbox

Test file for dynamically changing dropdown menu and listbox, which seems to
work just fine.

Updated

16 years ago
Keywords: evang500

Comment 4

15 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us

Updated

15 years ago
Summary: dropdown menu is not updated properly when changing it dynamically using javascript → naturalvoices.att.com - dropdown menu is not updated properly when changing it dynamically using javascript
(Reporter)

Comment 5

15 years ago
seems to be fixed as of today. (2003-06-21)
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.