[quirks]border cuts off at window height css

RESOLVED WONTFIX

Status

()

Core
Layout
--
trivial
RESOLVED WONTFIX
16 years ago
14 years ago

People

(Reporter: Brenda, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

The border at http://individual.utoronto.ca/brenbren/links.html is coded to
display at 100% height, but in Mozilla, it only displays to the height of the
window. When you scroll down, the border disappears. It runs to the bottom of
the page in both Opera and in IE6.

Reproducible: Always

Steps to Reproduce:
1. Open the page.
2. Scroll down.
3. Resize the window.
Actual Results:  
The double border running down either side of the text disappears at the bottom
of the original window: if you note the text at the bottom of the screen, then
you'll notice that the border only extends to the bottom of that window.

Expected Results:  
The border should have continued to the bottom of the page, as it does in both
IE6 and Opera.
This is a problem in quirks mode only; in standards mode things are fine.

Looks like the wacky hacks for height:100% that violate the CSS spec to make it
work inside tables are coming back to haunt us.
Summary: border cuts off at window height css → [quirks]border cuts off at window height css
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
I've found that this is not restricted to quirks mode. See
http://www.hopechurchshouthport.org/ethos.asp for an example.
So I bet the problem in IE is that it actually makes the body the size of the
content... we do not (correctly).  So 100% ends up being 100% of the viewport,
which is needed for cases when the body is _shorter_ than the viewport.

I feel we should just wontfix this.

Comment 4

14 years ago
Resolving WONTFIX. We do not want this to happen. We actually use this example
quite often to tell people the BODY element is not 100%.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.