Closed Bug 192237 Opened 22 years ago Closed 22 years ago

After setting a BAD url to src attribute of img tag (from javascript) is no more possible display any other image changing src attribute.

Categories

(Core :: Layout: Images, Video, and HTML Frames, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla1.4beta

People

(Reporter: vielfede, Assigned: jdunn)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

src attribute can be setted, but image doesn't appear!

Reproducible: Always

Steps to Reproduce:
1.imm.setAttribute("src", "a.jpg");// "a.jpg" doesn't exist!
2.imm.setAttribute("src", "b.jpg");// "b.jpg" exists!
3.

Actual Results:  
No images can be displayed on this img tag!

Expected Results:  
Just it has to display every time the right image conforming src content!
Attached file Bad src block image
Well, if you doing document.getElementById("imm").src to good URI into another
script session, image appeared.
Hmm? This one dupe bug 22820, but this one marked as "FIXED"? 
O'k. I mark this one as new, because it is not 100% dupe of bug 22820 -- this
effect happened if one of width and height is not defined (if both of them
stated, than patch for bug 22820 seems doing the job). 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Depends on: 83774
So... how do I reproduce this bug?
Copy testcase to local computer and press first button. Seems that I miscalc
something. 
I can't seem to reproduce this on win2k using 1.3a, hmmmm
Summary: After settig a BAD url to src attribute of img tag (from javascript) is no more possible display any other image changing src attribute. → After setting a BAD url to src attribute of img tag (from javascript) is no more possible display any other image changing src attribute.
I was able to reproduce this but I had to modify the
testcase to see the failure by changing the "valid"
image in InvalidateScr to something other than
"mozilla-banner.gif.  When I do that, if I click on
"click to make bad src" the "image" is then bad.
Status: NEW → ASSIGNED
Well, this is testcase, with changes according to comment #7 -- it show
incorrect behaviour, but only when I switch off proxy.
marking target (hopefully get this by 1.4)
Target Milestone: --- → mozilla1.4beta
Depends on: 198435
The tests now work due to the fix for bug 83774.  However there 
is still a dependency on bug 198435 so am reluctant to close 
this.
Fixed by bug 198435
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: