WinMe & Win98: Hangs after some use in browser (or retrieve messages in Mail)

VERIFIED DUPLICATE of bug 192294

Status

SeaMonkey
General
--
blocker
VERIFIED DUPLICATE of bug 192294
15 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: Samir Gehani)

Tracking

({hang})

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Trunk build 2002-02-07: WinMe, Win98

Overview: Today's builds install without a problem but after using the Browser
for a little while or retrieving Mail then it hangs. WinMe & Win98 only problem
since WinXP is ok. 

Steps to reproduce:
1. Open browser and click through some links, move scrollbar up and down

Actual Results: Hang

Another set of steps that makes this surface more predictabley:
1. Open Mail
2. Configure for a mail account
3. Retrieve messages and wait or retrieve message and create a new message

Actual results: Hang. I tried deleting the XUL.mfl file and I was able to use
the profile again but it quickly reverted and displayed the same problem.

Expected results: No Hang

Marking a blocker since it's impossible to use the app on WinMe or Win98.

Comment 1

15 years ago
can you send the corrupted XUL.mfl to jrgm@netscape.com since it was supposed to
be fixed with bug 188744 ?
Blocks: 189832

Updated

15 years ago
Keywords: hang

Comment 2

15 years ago
> Steps to reproduce:
> 1. Open browser and click through some links, move scrollbar up and down

That would not involve fastload (i.e., if the hang can happen while just 
interacting with the UI and not bringing up any other dialogs, then the 
fastload code will not have ever been called). 

The other description about mail/news and creating a new message is consistent
with how you _might_ hit this fastload hang, but it's kind of contradicted by 
the first example. The fastload hang is also not a platform dependent bug.

So, I'm a bit skeptical that this is the fastload hang you are seeing. But I 
would like to see the XUL.mfl file just to be more certain.

Note: there was another bug reported today that implicated the history.dat file
and having a hang on windows while just opening and closing tabs in tabbrowser 
(bug 192294).

Comment 3

15 years ago
I'm seeing this very often with 2003020908. I don't use mail but I belive that
this bug occurs after the browser has been left idle for a few moments.
Will a clean profile (and xul.mfl) help me?

Comment 4

15 years ago
Deleting XUL.mfl did _not_ help in my case (WinME & Mozilla build 20030208).

What helped in my case is the combination of uninstallling Mozilla and GRE (with
the uninstall programs) plus deleting the history (there is a separate bug about
hangs with a large history file). I'm unable to say which one saved the day.

I've re-installed Mozilla, of course ;-)

Comment 5

15 years ago
Using build 2003021008, going to www.netscape.com hangs after approximately 1
minute for me.  Build 2003020608 does not hang.  This is using the exact same
profile.

I also tried turning off Java and Javascript, but browser still hangs.  I never
invoked MailNews at all.

Comment 6

15 years ago
This is apparently a duplicate of bug 192294.

Comment 7

15 years ago
After more testing I see that uninstall and history delete did not solve the
problem. However to hit the problem I have to hit some specific webpages. Having
www.bluesnews.com in one of several open tabs means a sure doom for 20030209.

Comment 8

15 years ago
If it happened between 2003020608 and 2003020708, that means it's one of the
following: bug 191927, bug 191548, bug 191739, bug 190490, bug 181644, bug
190529,  bug 192009, bug 191021, bug 192049, bug 185698, bug 107002, bug 191675
or the very secret bug 191817.     

Comment 9

15 years ago
bug 192294 gives a lot of URLs producing a hanging browser on Win98 and Win98SE,
in a new, unused programm directory, with a new, unused profile.
I even got a hang when I opened links in the background, while I was reading an
article. One of the links led to www.cnn.com, which produced a hang after a while.

It must be a regression, as told in comment #5 Build ID: 2003020608 is my last
working browser, from 20030207 on mozilla and phoenix are producing hangs, some
time after loading sites like www.microsoft.com, www.netscape.com, www.cnn.com.
Links in bug 192294.

Comment 10

15 years ago
Build 2003020704 also hangs, which narrows things down a tiny bit.

Comment 11

15 years ago
Warner, what OS are you using, 98, 98SE, ME or something different?

Comment 12

15 years ago
Hermann, I'm using Win98 SE.  I did a quick test on XP, and it didn't hang, so
that seems in keeping with the theory that this is Win9x only.

Comment 13

15 years ago
If 2003020704 was OK, then the reason for this regression is either bug 192272
or bug 192196. These were the only bugs fixed between February 7th morning and
9th noon Pacific Time (both fixes checked in actually on 7th afternoon). 

Both were checked in by darin@netscape.com. He is already on the CC: list.

BTW, this is definitely a show stopper.

Comment 14

15 years ago
> If 2003020704 was OK...

Uh, comment 10 said that 2003020704 "also hangs".

Comment 15

15 years ago
comment #13 is wrong.  this would have been caused by checkins occuring on the
6th not the 7th.  i've been able to repro the hang.  marking as duplicate.

*** This bug has been marked as a duplicate of 192294 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
clearing 1.3b? flag, as this was marked duplicate
Flags: blocking1.3?

Comment 17

15 years ago
My comment #13 logic was OK but I garbled the message (it should have read "if
2003020704 is bad..."). Sorry for the confusion.

Verifying Duplicate

Comment 18

15 years ago
Now really verifying :-(
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.