pasting part of <pre> should not preserve blockness of <pre>

RESOLVED INVALID

Status

()

RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: jruderman, Assigned: mozeditor)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Steps to reproduce:

1. Type a sentence into a message compose window.
2. Type a quote-mark.
3. Paste a sentence from a bugzilla comment.
4. Type a quote-mark.

Result: step 3 creates a monospace block.

Expected: since I only pasted part of a <pre>, pasting shouldn't create a new
block.  Pasting it as <pre style="display: inline"> may be acceptable, assuming
the HTML-to-plaintext converter for sending messages handles it correctly,
including making sure no lines are longer than 80 chars unless they need to be.
(Assignee)

Comment 1

16 years ago
headers ad pre's are special blocks in our copy code.  We preserve them even if
you don't select al of them.  This is intentional, although somewhat
controversial (especially for pre).  

It's possible in the future that this may change.  For now you'll have to either
mark the text as body text, or backspace it into the previous block.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

16 years ago
This isn't a bug about code, this is a bug about behavior.  If you know what
this is a dup of, mark it as a dup.  If you know a more general summary, change
the summary.  But don't mark it as invalid without a good reason.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Comment 3

16 years ago
The behavior is intentional.  It's possible that we will revisit this.  But in
the meantime, it's not a bug.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

16 years ago
E-mails from joe:

----------

The issue rasied in bug 192360 has history.  There have been many many
discussions internally years back about this.  You might be amused to know that
I argued your side on occassion.

The reason I closed it as invalid was the reason I gave: the behavior is
intentional.  A large number of folks considered what should happen when you
copy and paste part of a pre, and (believe it or not) that was the solution they
wanted. 

...

[T]hese were internal discussions early on, when the editor was being first written.

Doing things like pasting a <pre> with display:inline gives compatibility
problems with older mail clients. 

----------

I'm still not convinced that this bug shouldn't be fixed, but that's a lot
better than saying "this is intentional".

I hit this bug occasionally when trying to quote from e-mails.
You need to log in before you can comment on or make changes to this bug.