All users were logged out of Bugzilla on October 13th, 2018

When using RealVNC, Mail Crash when Subject contains newline (and/or tab?)

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: jay, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Am migrating mail from NS 4.76 (Linux RH 6.x) to Mozilla 1.2 on Linux Red Hat 8.
This problem did not exist with the very same messages on NS 4.76

Am Using Windows 95 PCs as workstations with RealVNC to provide the X display of
the Linux on the PCs.  The Mozilla is running on the RH8 and being viewed
through VNC. The RealVNC server (on the RH8 server) is the standard supplied as
part of RH8. The RealVNC client on the PCs is 3.36 -- very recent.

Mail is on IMAP (UW 2001a) as provided by standard RH8 install.

The 80,000+ mail messages that I am migrating contain a few (hundreds?) messages
with malformed headers that contain a NEWLINE TAB in the SUBJECT.  I am guessing
that this occurred as the result of pasting something into the Subject line when
the message was originally sent.

I am guessing that the TAB was added by a mail program or server in the same way
that TABs appear to be added to "Received-From" lines, etc.  In any case, I
believe that the problem is the NEWLINE, not the TAB.

When a mailbox that contains such a header is clicked on in the left pane of
Mozilla Mail:

a) If the offending mail message IS in the visible header list in the upper
right pane, then Mozilla CRASHES immediately.

b) If the offending mail message is NOT in the visible header list in the upper
right pane (because there are lots of messages either before or after it),
Mozilla will not immediately crash at that moment, but WILL IMMEDIATELY CRASH as
soon as you scroll to a point where the message header line is (or is about to)
become visible.

[I suspect also that if INBOX contains such a message, then Mozilla will either
crash on startup or will crash as soon as the user scrolls to that message in
the header list. In that case, it would be extremely difficult to diagnose the
problem.]

THE PROBLEM IS: When the Subject line is "unfolded" because of the newline (SEE
extensive conversation at Bug 64948), a REALLY FUNKY NON-ASCII CHARACTER
"N-over-L" is being put by Mozilla into the subject line IN THE UPPER RIGHT
PANE.  (This character is NOT being put above the message in the lower right pane.)

VNC is choking on this character and crashing.  (I will bring this to their
attention also!).  However, I do not believe that this is entirely a VNC
problem.  There is no reason why the funky "N-over-L" character should be put in
the text.  Based on my limited understanding of the conversation at Bug 64948,
this "N-over-L" character is inappropriate.

When I say "N-over-L" character, I must explain that this is what I see when I
look at the same email message both on my RH8 server console and on Cygwin 3.36
running on a Windows 95 PC.

I have tested this about 25 times, changing the Imap mail message text file in
various combinations, etc.  I have deleted the XUL.mafls file numerous times.  I
have deleted the mailboxname.msf file each time I tested.  I think I have it
covered.

Reproducible: Always

Steps to Reproduce:
Please see above.
Actual Results:  
Crashed ALL Mozilla for this user.

Expected Results:  
Not crashed.

I will follow up with attachments of the mail message file and the .msf file.
(Reporter)

Comment 1

16 years ago
Created attachment 113875 [details]
mail message with "newline tab" in subject line

This mailbox has been pared down to this single message.
I will follow the the .msf file for this mailbox/message.
(Reporter)

Comment 2

16 years ago
Created attachment 113878 [details]
msf file for mailbox with subject line with newline tab

Notice that the subject line contains [I am putting a space between the dollar
sign and the following characters to prevent any translation in this process] $
0A $ 09 in front of the the text "1234".  I believe that is what is crashing
VNC and generating the "N-over-L" character on the RH8 server console and
through Cygwin.
(Reporter)

Comment 3

16 years ago
a) The .msf file shows "$0A$09" (in case that does not come through, it is
"dollar sign zero A dollar sign zero 9" where the newline tab appear in the
subject line in the mailbox file.

b) NOTE: You should be able to confirm the "N-over-L" using a standard RH8
server console.  (We have the standard encoding on the server set to ISO-8859-1
instead of UTF-8, in case that makes a difference.  The RH8 change to UTF-8
broke a lot of our database related programs, thus we have to stick with
ISO-8859-1 for the moment.)

c) NOTE: As far as I know, you will probably only be able to repeat the CRASH if
you try to test with VNC.  The easiest fix is to convert the newline tab to
plain spaces when 1) creating the .msf file and 2) when rendering the message.
Summary: When using RealVNC, Mail Crash when Subject contains newline (and/or tab?) → When using RealVNC, Mail Crash when Subject contains newline (and/or tab?)
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail
Reporter:
Do you still see this with a recent Build ?
If yes: Can you please proivde a talkback ID from that crash ?
(Reporter)

Comment 5

14 years ago
Hi,

I no longer (two years later) have that environment available.  I don't have
those migrated messages available and we are no longer using RealVNC in this way.

It sure would have been nice if somebody had looked at this two years ago. I
feel like I wasted a lot of time on this issue -- and other issues -- trying to
be helpful, but nobody seemed to be interested.

I don't know what should be done with the status.  WORKSFORME does not seem
correct.  I think it should be left unconfirmed, but closed, since it does not
seem to bother anybody else.

Jay
Sorry !
The problem is the number of developers and also bug triagers like me and the
flood of incoming bug reports.
Example:
SSpitzer (the old developer) had over 3000 open bug reports assigned to him (!).

Your case seems to be a real edge case because nobody else reported this.

I mark this worksforme (no other way to close it). You can reopen this bug again
if you or anybody else see this again.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

14 years ago
Understood.  Sounds like the best plan.

I just wish I had the technical knowledge to actually do some good in this
process.  

I will make one comment and that is that the "barrier to knowledge" is too high.
 I have very modest programming knowledge, though I have been operating a
network and a company for many years.  Yet when somebody replies that a new
build is to be installed and a talkback to be supplied, etc, etc., I have *NO*
idea how to proceed with that.  There is far too great an assumuption of
knowledge, by those that have it, regarding those that don't have it.  A few
"how to do this" web pages directed at the intelligent-but-untrained might do a
world of good. Just my two cents worth.

Thanks much. 

Jay
You need to log in before you can comment on or make changes to this bug.