Mangled prefs.js file causes freezes on "Save..." and sending mail

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
16 years ago
14 years ago

People

(Reporter: SGwylan, Assigned: bugs)

Tracking

Trunk
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.3a) Gecko/20021210
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.3a) Gecko/20021210

This one is a bit odd and may be OS/2-specific, but I'm not sure. At some point
I lost the ability to save pages/files or to send or "send later" any mail. I
solved the problem by looking at the prefs.js file and noticing that the printer
settings for a new printer were mangled... not so bad that an error message was
produced when loading, but obviously screwy. See "Additional Information."

Reproducible: Always

Steps to Reproduce:
1. Try "Save Page As" or "Save link target as" in browser or "Send" or "Send
Later" in composed e-mail.

Actual Results:  
Mozilla freezes; CPU monitor pins at 100%; have to force brower closed.

Expected Results:  
File (of some sort) written to drive.

prefs.js *had*:

user_pref("print.
ter_Epson_Stylus_Color_760_Inkjet_printer.print_paper_height", " 11.00");
user_pref("print.
ter_Epson_Stylus_Color_760_Inkjet_printer.print_paper_size_type", 1);
user_pref("print.
ter_Epson_Stylus_Color_760_Inkjet_printer.print_paper_size_unit", 0);
user_pref("print.  8.50", "  8.50");
user_pref("print.printer_Epso╟└└7πáV╝", "");
user_pref("print.printer_Epson_Stylus_Colî", true);
user_pref("print.printer_Epso╕≈>╪l/ X,", "");
user_pref("print.printer_Epso╨Φ( X,", "");
user_pref("print.printer_HL-1440.print_command", "");
user_pref("print.printer_HL-1440.print_in_color", true);
user_pref("print.printer_HL-1440.print_paper_height", " 11.00");
user_pref("print.printer_HL-1440.print_paper_size_type", 1);
user_pref("print.printer_HL-1440.print_paper_size_unit", 0);
user_pref("print.printer_HL-1440.print_paper_width", "  8.50");
user_pref("print.selection_radio_enabled", false);
user_pref("print.ábìter_Epson_Stylus_Color_760_Inkjet_printer.print_paper_height",
" 11.00");
user_pref("print.ábìter_Epson_Stylus_Color_760_Inkjet_printer.print_paper_size_type",
1);
user_pref("print.ábìter_Epson_Stylus_Color_760_Inkjet_printer.print_paper_size_unit",
0);
user_pref("print.ágñter_Epson_Stylus_Color_760_Inkjet_printer.print_paper_height",
" 11.00");
user_pref("print.ágñter_Epson_Stylus_Color_760_Inkjet_printer.print_paper_size_type",
1);
user_pref("print.ágñter_Epson_Stylus_Color_760_Inkjet_printer.print_paper_size_unit",
0);

In case the garbage chars don't show well, here's a partial hex-dump from the
top of the above segment:

            0  1  2  3  4  5  6  7    8  9  A  B  C  D  E  F                   
000051E    22 29 3B 0D 0A 75 73 65 ═ 72 5F 70 72 65 66 28 22   ");  user_pref("
000051F    70 72 69 6E 74 2E 20 07 ═ 02 01 74 65 72 5F 45 70   print. ter_Ep
0000520    73 6F 6E 5F 53 74 79 6C ═ 75 73 5F 43 6F 6C 6F 72   son_Stylus_Color
0000521    5F 37 36 30 5F 49 6E 6B ═ 6A 65 74 5F 70 72 69 6E   _760_Inkjet_prin
0000522    74 65 72 2E 70 72 69 6E ═ 74 5F 70 61 70 65 72 5F   ter.print_paper_
0000523    68 65 69 67 68 74 22 2C ═ 20 22 20 31 31 2E 30 30   height", " 11.00
0000524    22 29 3B 0D 0A 75 73 65 ═ 72 5F 70 72 65 66 28 22   ");  user_pref("
0000525    70 72 69 6E 74 2E 20 07 ═ 02 01 74 65 72 5F 45 70   print. ter_Ep
0000526    73 6F 6E 5F 53 74 79 6C ═ 75 73 5F 43 6F 6C 6F 72   son_Stylus_Color
0000527    5F 37 36 30 5F 49 6E 6B ═ 6A 65 74 5F 70 72 69 6E   _760_Inkjet_prin
0000528    74 65 72 2E 70 72 69 6E ═ 74 5F 70 61 70 65 72 5F   ter.print_paper_
0000529    73 69 7A 65 5F 74 79 70 ═ 65 22 2C 20 31 29 3B 0D   size_type", 1);
000052A    0A 75 73 65 72 5F 70 72 ═ 65 66 28 22 70 72 69 6E   user_pref("prin
000052B    74 2E 20 07 02 01 74 65 ═ 72 5F 45 70 73 6F 6E 5F   t. ter_Epson_
000052C    53 74 79 6C 75 73 5F 43 ═ 6F 6C 6F 72 5F 37 36 30   Stylus_Color_760
000052D    5F 49 6E 6B 6A 65 74 5F ═ 70 72 69 6E 74 65 72 2E   _Inkjet_printer.
000052E    70 72 69 6E 74 5F 70 61 ═ 70 65 72 5F 73 69 7A 65   print_paper_size
000052F    5F 75 6E 69 74 22 2C 20 ═ 30 29 3B 0D 0A 75 73 65   _unit", 0);  use
0000530    72 5F 70 72 65 66 28 22 ═ 70 72 69 6E 74 2E 20 20   r_pref("print.
0000531    38 2E 35 30 22 2C 20 22 ═ 20 20 38 2E 35 30 22 29   8.50", "  8.50")
0000532    3B 0D 0A 75 73 65 72 5F ═ 70 72 65 66 28 22 70 72   ;  user_pref("pr

This was hand corrected to:

user_pref("print.printer_Epson_Stylus_Color_760_Inkjet_printer.print_command","")
user_pref("print.printer_Epson_Stylus_Color_760_Inkjet_printer.print_in_color",
true);
user_pref("print.printer_Epson_Stylus_Color_760_Inkjet_printer.print_paper_height",
" 11.00");
user_pref("print.printer_Epson_Stylus_Color_760_Inkjet_printer.print_paper_size_type",
1);
user_pref("print.printer_Epson_Stylus_Color_760_Inkjet_printer.print_paper_size_unit",
0);
user_pref("print.printer_Epson_Stylus_Color_760_Inkjet_printer.print_paper_width",
"  8.50");
user_pref("print.printer_HL-1440.print_command", "");
user_pref("print.printer_HL-1440.print_in_color", true);
user_pref("print.printer_HL-1440.print_paper_height", " 11.00");
user_pref("print.printer_HL-1440.print_paper_size_type", 1);
user_pref("print.printer_HL-1440.print_paper_size_unit", 0);
user_pref("print.printer_HL-1440.print_paper_width", "  8.50");
user_pref("print.selection_radio_enabled", false);

And everything worked fine again. It looks like the names were mangled from the
first time they were referenced (I back up my profiles directory every 12 hours
but only keep one a week after midnight Sunday), but the filing problems didn't
happen until possibly after the following error was caught in popuplog.os2:

02-06-2003  01:14:46  SYS3190  PID 01b0  TID 0001  Slot 0097
C:\WARPZILLA\121\MOZILLA\MOZILLA.EXE
c000001d
01f26d40
EAX=02d5bb60  EBX=023ac78c  ECX=01ad5f50  EDX=00000000
ESI=00000000  EDI=00131850  
DS=0053  DSACC=d0f3  DSLIM=bfffffff  
ES=0053  ESACC=d0f3  ESLIM=bfffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:01f26d40  CSACC=d0df  CSLIM=bfffffff
SS:ESP=0053:0013182c  SSACC=d0f3  SSLIM=bfffffff
EBP=001318c0  FLG=00012206

MOZRMI36.DLL

Comment 1

16 years ago
The pref horkage was fixed a while back, on Dec. 20th in bug 185588
Interesting if it really causes all those other bugs you observed.
Do you have a copy of the broken file?
(Reporter)

Comment 2

16 years ago
Created attachment 113907 [details]
Mangled prefs.js file
(Reporter)

Comment 3

16 years ago
Created attachment 113908 [details]
Fixed prefs.js file
(Reporter)

Comment 4

16 years ago
Created attachment 113910 [details]
Mangled prefs.js file that didn't cause problems described
(Reporter)

Comment 5

16 years ago
I've added before, during and after problem versions of prefs.js file. I'm not
sure what the causality might be; I didn't really expect my fix to work, but it
did and that was the only change I made. <shrug>

Comment 6

16 years ago
Checking if the prefs.js horkage is a red herring or not (suspecting dup of bug
169777)

If you backup the fixed prefs.js and restore the mangled one that caused the
bugs: Do the same bugs surface again?

If yes: If you quit moz, delete XUL.mfl, then restart (still using the mangled
prefs.js): Do you still see the bugs?

(Reporter)

Comment 7

16 years ago
Doing as requested didn't seem to break anything, though the XUL.mfl file shrank
considerably (from 2,199,134 bytes to 1,535,776 bytes. 

I had a bug report open a while back that was resolved by forcing an XUL.mfl
rebuild and something I didn't report (didn't think about it that much, but
typing or pasting into mail replies, I could insert newlines in the quotebacks,
but the text would go other than where the cursor was(!)) could be considered
related behaviour.

All of my backups suggest my problems all occurred during the existence of a
particular XUL.mfl build, though things worked within the first two hours of
that build's existence. Odd that there was no rebuild after the SYS3190, but....

Thanks!

Comment 8

16 years ago
Thanks. Then this was likely a duplicate of bug 169777, but resolving as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
v per reporter.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.