Last Comment Bug 192409 - Mozilla does not support XML for musicians (MusicXML)
: Mozilla does not support XML for musicians (MusicXML)
Status: RESOLVED WONTFIX
BLOCKED: needs a spec, a comprehensiv...
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: P4 enhancement with 4 votes (vote)
: Future
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
http://www.musicxml.org/xml.html
: 232381 (view as bug list)
Depends on: 39965
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-08 08:42 PST by Dominik
Modified: 2009-08-24 04:53 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Dominik 2003-02-08 08:42:24 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; PL; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; PL; rv:1.2.1) Gecko/20021130

Mozilla does not support XML for musicians (for example MusicXML) it is
important (the same important like MathML) because we can't see gitar or bas
tabs and notes.

Reproducible: Always

Steps to Reproduce:
Comment 1 Ruslan Ismailov 2003-02-08 09:10:58 PST
Well. I could provide a link. http://www.musicxml.org/xml.html. But this one
does not w3c standart?
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2003-02-08 10:47:25 PST
It does not matter whether it's W3C or not as long as there is a need for it and
a clear specification....

This would be a good deal of work in the current layout world, I suspect.... 
(and it's not an XML bug per se).

Dominik, are there tools that _do_ support MusicXML?  Are there any test pages
to test implementations on?  A test suite, perhaps?
Comment 3 Benjamin Smedberg [:bsmedberg] 2003-02-08 11:14:22 PST
MusicXML has been championed by Recordare (http://www.musicxml.org) and is
supported by a number of music-typesetting programs including Finale. However,
the specification is far from a "version 1.0".

IMO any music layout code is well beyond the goals of mozilla proper; it would
introduce unncessary bloat for a little-used feature. Furthermore, since
MusicXML documents are block-level elements, it would be fairly easy to support
MusicXML would be through a plugin.

The only way this would ever work within gecko itself, is if we're planning on
"pluggable layout extensions" (bug 39965). Marking the depedency, and
recommending that this bug be WONTFIXed.
Comment 4 Dominik 2003-02-09 05:43:12 PST
>Dominik, are there tools that _do_ support MusicXML?
No and it is very very big problem so maybe first.

>Are there any test pages to test implementations on?  A test suite, perhaps?
Yes, http://www.musicxml.org/xml/helloworld.html 

IMO it is really important problem because today people (not only musicians)
published sides in txt files (it is horrible because sometimes characters or
sybmols must be colourful, bold etc). Some of them published sides in graphic
files (jpeg, gif or png, but it is horrible too because we can't edit this
files). Mathematicians, physicists and chemists have MathML (chemists has also
SVG - CML) other scientists does not need any XML but there are musicians which
do not sufficient XMLs like XHTML. Musicians need other XML (may be not all
MusicXML because some elements are too complicated to basic published).
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2003-02-09 10:54:23 PST
Dominik, is that the _only_ thing to test on?

Let me put it this way.  Any implementation of MusicXML will need to be tested
on a bunch of pages that test all (or at least most) of the functionality in
MusicXML, including various combinations of features.  Creating such a test
suite is, in my opinion, a prerequisite for any implementation work....
Comment 6 Hixie (not reading bugmail) 2003-02-22 08:07:34 PST
An implementation of MusicXML is also going to need a spec. I looked all over
that site but I couldn't find a specification anywhere.

Also, what real advantage is there to us implementing this? MusicXML is an
interchange format, not a presentation format -- its intended use if for
swapping between music authoring tools. Mozilla is not a music authoring tool
but a Web browser. Users of MusicXML will almost certainly be wanting to print
the sheet music, or play the music through a synthesiser. I can't imagine them
wanting to browse the sheet music in their Web browser, really.
Comment 7 Dominik 2003-02-22 13:21:03 PST
Ian 'Hixie' Hickson, I do not agree with you. There are a lot of Web sides with
gitar (bas and drums) tubs (I think there are more "Music tab sides" then MathML
sides). I agree with you that Mozilla should not play the music through a
synthesiser but Mozilla should show visual things like gitar tabs.
Comment 8 Nicholas Allen 2004-01-27 20:32:57 PST
*** Bug 232381 has been marked as a duplicate of this bug. ***
Comment 9 Arthit Suriyawongkul 2004-01-27 21:07:41 PST
MusicXML
http://www.recordare.com/xml.html

DTDs
http://www.recordare.com/dtds/index.html
Comment 10 Benjamin Smedberg [:bsmedberg] 2004-01-27 22:05:12 PST
DTDs and XML schemas aren't going to do us any good. We would need a spec
describing how to *render* MusicXML. I am so tempted to INVALID this bug, this
is much better implemented as a plugin (or perhaps as XBL+xul:canvas ifever I
can get that stable and approved).
Comment 11 Hixie (not reading bugmail) 2004-01-28 04:02:11 PST
Note that even with a spec and a comprehensive test suite (both of which are
absolute prerequisites for this -- unless someone provides these, nothing is
going to happen here), even with a spec and a test suite, this would still be
more work than implementing MathML (which took several years) and on par with
implementing SVG (which is still ongoing). Music is insanely hard to render.
Comment 12 Dominik 2004-01-29 08:28:38 PST
OK, so maybe Mozilla support W3C InkML (Ink Markup Language). It is more
universal and it can by also used in text, drawing, math, chemistry etc. Look at
http://www.w3.org/TR/2003/WD-InkML-20030806/ and http://www.w3.org/TR/InkML/
Comment 13 Anne (:annevk) 2005-03-23 06:27:52 PST
Is this a serious request? I read the whole bug and when I read comment 12 it
seems like someone just likes to see Mozilla implementing random XML formats.
Comment 14 Benjamin Smedberg [:bsmedberg] 2009-08-24 04:53:08 PDT
Not going to implement in core... you're welcome to implement it as a webapp with an SVG/canvas implementation.

Note You need to log in before you can comment on or make changes to this bug.