Cannot disable JavaScript with new UI

VERIFIED FIXED

Status

()

--
major
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: noririty, Assigned: bugs)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030208 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030208 Phoenix/0.5

Cannot disable JavaScript using the new preference dialogbox.
This phenomenon was noted after checkin of Bug 191524 (Mega Preferences Reorg.).

Reproducible: Always

Steps to Reproduce:
1.Start Phoenix with a new profile.
2.Open [Tools]-[Options...]-[Web Features].
3.Un-check "Enable JavaScript" checkbox.
4.Click [OK] to close options dialogbox.
5.Reopen [Tools]-[Options...]-[Web Features].
Actual Results:  
"Enable JavaScript" checkbox is checked
 and JavaScript is still enabled.

Expected Results:  
"Enable JavaScript" checkbox must be un-checked
 and JavaScript should be disabled.

This bug has been reported:
http://www.mozillazine.org/forums/viewtopic.php?t=5441
http://bugzilla.mozilla.org/show_bug.cgi?id=191650#c6
(Reporter)

Updated

16 years ago
Blocks: 191524
Keywords: regression
Confirming and reassigning to Ben.
Assignee: blaker → ben
Status: UNCONFIRMED → NEW
Ever confirmed: true
Actually, you don't even need to close the Options window and to open it again.
Just uncheck "Enable javascript", then switch to another Options panel and
switch back to the Web Features panel, and the pref is checked again.
(Reporter)

Comment 3

16 years ago
Created attachment 115708 [details] [diff] [review]
fix

fix Mega Preferences Reorg. regression
(Reporter)

Comment 4

16 years ago
Created attachment 115710 [details] [diff] [review]
fix v.2

This version of the patch also fixes the initial button enable/disable.
Attachment #115708 - Attachment is obsolete: true
(Reporter)

Updated

16 years ago
Attachment #115710 - Flags: review?(chanial)

Comment 5

16 years ago
Comment on attachment 115710 [details] [diff] [review]
fix v.2

It was the other way around :)
Thank you for pointing at the problem!
Attachment #115710 - Flags: review?(chanial) → review-

Comment 6

16 years ago
fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Updated

16 years ago
Attachment #115710 - Attachment is obsolete: true
(Reporter)

Comment 7

16 years ago
Created attachment 115757 [details] [diff] [review]
Patch a deficiency

This patch fixes following deficiency.
1. Open [Tools]-[Options…]-[Web Features]
2. Un-check [Enable JavaScript]
*note Advanced button is disabled.
3. Switch to another Options panel and switch back to the Web Features panel.
Actual Results: 
Advanced button is enabled

Expected Results: 
Advanced button should be disabled
(Reporter)

Updated

16 years ago
Attachment #115757 - Flags: review?(chanial)
*** Bug 195228 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
I grabbed today's nightly and it works fine with new profiles and 0.5 profiles.
I experienced a problem with a post pref reorg profile, though.
Try with a new profile.

Comment 10

16 years ago
Ooops, sorry, norority, I didn't understand the bug correctly, now the
'advanced' button is really fixed.
Thanks!

Comment 11

16 years ago
Comment on attachment 115757 [details] [diff] [review]
Patch a deficiency

I refactored some code, though. but this patch and the previous one were
essentially correct.
Attachment #115757 - Flags: review?(chanial) → review+
(Reporter)

Comment 12

16 years ago
Pierre:
Thanks for the review and polishing.

v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.