Tilde doesn't work in URL window, in email composer nor in composer

RESOLVED DUPLICATE of bug 182229

Status

()

Core
Editor
RESOLVED DUPLICATE of bug 182229
16 years ago
15 years ago

People

(Reporter: Ari Kaihola, Assigned: Joe Francis)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021213
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021213

Tilde works all right in Kate editor though, so this must be Mozilla specific. 

I'm using Mandrake 9.1 beta 3. PC has AMD processor and VIA KT133A chipset.
This bug report 176713 has same problems, but not quite. The guy seems to be
from Finland as I am, so maybe this has something to do with finnish keyboard
layout - but how only with Mozilla?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211
Build ID: 2003021120

I am also experiencing this problem.
$LANG=sv_SE.iso885915
Dist: RedHat 8.0
Both dead_tilde and dead_circumflex are "dead" to me in Mozilla. They work in
other applications like gnome-terminal.

Comment 2

16 years ago
If this is on gtk2 builds, I am fairly confident it is because of bug 176514.

Comment 3

16 years ago
This doesn't look like it's the same bug as bug 176514, in that bug there are
reports of not being able to type characters to gnome-terminal and i repeated
the steps on my machine and it works like planned.

I can reproduce this on Debian with both Mozilla stable (the 1.3 build) and
mozilla snapshot (it's been there atleast a month now)

The mozilla in debian has been built against gtk2 so it might be gtk2 related
issue, but atleast it's not exactly the same as 176514.

Comment 4

16 years ago
And even more information. The patch from bug 176514 was applied to debian build
and this bug has disappeared.

Comment 5

16 years ago
I experience the same thing (debian), with both tilde and circumflex

It doesn't seem like a gtk2 bug though. both tilde and circumflex work in the
latest freeciv gtk client (which is IMHO based on gtk2). Maybe this is
interesting too: you have to press those characters twice in order to get one.
if you press say tilde followed by an 'a', you'd get an "a" with a tilde on it.

I hope this can be fixed soon.

Comment 6

15 years ago
blizzard--is this a dupe of bug 182229?
resolving as such; please reopen etc. if not.

*** This bug has been marked as a duplicate of 182229 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.