automatic URL detection in text mails cuts off last character

RESOLVED DUPLICATE of bug 185377

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 185377
15 years ago
13 years ago

People

(Reporter: Eduard Rysavy, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030206
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030206

IN a mail with:
Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable
if on the last line I've got something like:
URL: http://www.xxx.abc
then "http://www.xxx.ab" gets converted to a link

In a mail with
Content-Type: text/plain
Content-Transfer-Encoding: 7bit
everything works okay.

Reproducible: Always

Steps to Reproduce:
1. receive a mail with the described headers and content
2. open mail in reader
3. try to click on the link -> wrong URL

Actual Results:  
last character cut off (presumably if last character in message or line, not
checked)

Expected Results:  
full URL correctly detected

Comment 1

15 years ago
May this be related to Bug 183111 ? However, the patch was attached on Feb 8th,
so your this bug could not be produced by the new code.
(Reporter)

Comment 2

15 years ago
Some more details:
- I'm not sure if I've the old or new code here; I've got Build ID 2003020905
now, same problem
- I'm using IMAP, don't know if this makes a difference
- It happens only for the last letter in the mail.
If you write a message with Mozilla, there always seems to be a newline attached
at the end. For the messages I'm having this problem with, the last character in
the mail is the last character of the URL, no trailing newline.
So perhaps the checking routine doesn't get this character passed as an argument
at all. This view seems to be supported by the fact that this only happens in
quoted-printable encoded mails (that's the only difference between those mails)

Comment 3

15 years ago
DUP. Thanks for the additional info re qp and end-of-line.

*** This bug has been marked as a duplicate of 185377 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.