Fails to block popup using document.body.appendChild

RESOLVED DUPLICATE of bug 159036

Status

RESOLVED DUPLICATE of bug 159036
16 years ago
14 years ago

People

(Reporter: magus, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030205 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030205 Phoenix/0.5

All popup blocking enabled, this page still loads a popup, possibly because it
is appending the script using document.body.appendChild, so maybe that is
bypassing the blocking?



Reproducible: Always

Steps to Reproduce:
1. Go to http://thisoldhaus.com/tests/popup_test/

Actual Results:  
Popup appears.

Expected Results:  
No popup - should have caught blocking.

Comment 1

16 years ago
No popup when user_pref("dom.disable_open_click_delay", 1000); is set.
Marking as a dupe of the bug asking for a whitelist of techniques that are
'valid' for allowing popup windows (such as clicking a link, or submitting a
form), because blacklisting techniques such as this is not feasible.

*** This bug has been marked as a duplicate of 159036 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.