For Redhat 8.0, all versions of Mozilla and Netscape 7.0 for Linux and Windows cannot connect to imap ssl port 995

RESOLVED FIXED

Status

MailNews Core
Networking: IMAP
--
major
RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: Mark Nielsen, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

I have tried to use imap over a secure connection to a Redhat 8.0 os running
imaps on port 995. For all versions of Netscape 7.0 and Mozilla on Linux and
Windows, I get various error messages about not being able to connect to the
imaps server. 
However, pop3, imap, and secure pop work just fine.  
In addition, Netscape 4.x on Linux and MicroSoft Outlook (from windows 98) work
fine as well. 

This tells me the problem is with Mozilla and not the server. 

Reproducible: Always

Steps to Reproduce:
1. run imaps on Redhat 8.0 server on port 995 with xinetd.
2. Use any version of Mozilla (I tested 1.x, 1.2, and 1.3a) on either Linux or
Windows.
3. Set the account to use ssl for imap. 

Actual Results:  
Different errors for different versions of Mozilla. 
1. Mozilla 1.1 said "incorrect Message Authentication Code". 
2. Mozilla 1.2 ans 1.3a had different errors messages. 

Expected Results:  
let me login into imap ssl to read my email. 

I am willing to test any new version of Mozilla with imaps on the RedHat 8.0
server. 

I haven't tested Mozilla on any other imap ssl server. 
Mark

Comment 1

16 years ago
According to bug 49164, you can set non-default ssl port numbers in the account
settings. (default being port 993). Is that what doesn't work?

Comment 2

16 years ago
also bug 192272 which was just fixed and bug 190106 which is currently
being worked on and maybe similar to your bug.

you might want to try a more recent build also as we are going to 1.3b.
(Reporter)

Comment 3

16 years ago
This was fixed. 
When I went into /usr/share/ssl/certs
and ran
make imap_new.pem
and then copied that to imap.pem
multiple versions of mozilla worked. 
Mozilla 1.3b also gave a nice error message (before) which helped a lot. 
What is interesting is that if your cert is not setup right, earlier versions of
mozilla still can connect to it even though it can't to imap. Weird. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

16 years ago
From my earlier message, I meant to say
earlier versions of Mozilla would still connect to secure pop even with a bad
certificate. It just wouldn't connect to secure imap with a bad certificate. 
That was weird. 
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.