Border+background is drawn wrong for an image

RESOLVED INVALID

Status

()

RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: zanstra, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+

The image in the left bottom corner (gids.com, the first one below "Banners")
has a border, a background-color and padding/margin specified. The css-box is
smaller than the image itself.
The box is drawn around the text "Zoeken en vinden in uw regio", but the big
letters "gids.com" belong to the image as well. The border is black, and the
background-color is something yellow-redish.

Reproducible: Always

Steps to Reproduce:
Just load the page
Actual Results:  
The border+background is around the text "Zoeken en vinden in uw regio"

Expected Results:  
The border+background should be drawn around the whole picture, including the
line "gids.com"

This happens in Mozilla 1.2.1 on Mac OS X as well

Comment 1

16 years ago
WorksForMe using Chimera/2003021707 and FizzillaMach/2003022103. Reassigning to
Browser per comment 0.

Doeke, can you still reproduce this problem using a current nightly build? If
so, can you reproduce this problem using another Mozilla user profile?
Assignee: saari → other
Component: General → Layout
Product: Chimera → Browser
QA Contact: winnie → ian
Version: unspecified → Trunk
(Reporter)

Comment 2

16 years ago
Yes, the URL I submitted with this bug is "fixed". I think (but am not 100% 
sure) this is not a bug. I put the CSS (which was first on the URL I submitted) 
on a seperate page:
http://www.xs4all.nl/~zanstra/inTec/mozillaBug-boxing-model.htm

I gave a height property to an A tag, which is an inline-tag. I think that's 
not allowed. The background color was applied to the line-height. So the 
question is: if an image is heigher than the line-height, should the background 
of the complete image be in that color, or is the behaviour correct?

Comment 3

16 years ago
You need to change add display:block to your A element.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.