Print Preview --> Print --> Back creates inescapable Print Preview

RESOLVED DUPLICATE of bug 177278

Status

()

--
critical
RESOLVED DUPLICATE of bug 177278
16 years ago
16 years ago

People

(Reporter: linux, Assigned: rods)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

My first bug -- sorry for any conventions I've violated.

For any given web page, if you'd visited webpages before it in the same tab or
window, this problem could arise.  Rather tricky one, but it can cause loss of
data if multiple tabs are open.  Probably even if only one tab is open.

When in print preview mode after printing a page, "back" and "forward" are
allowed (keyboard, mouse buttons, or right-click) and if used, "close" no longer
works.  User must shut down Mozilla completely, losing any data in this or other
open tabs.

Reproducible: Always

Steps to Reproduce:
1. Go click through a series of links.
2. Late in the series, print preview the page.
3. Print the page
4. Browser returns to print preview.
5. Try to go back or forward (using keyboard, mouse, or left-click) and notice
you are successful, not met with "page cannot change" message.


Actual Results:  
User will be unable to close print preview mode using "close" button.  User must
then close instance of Mozilla using alt-f4 or right-clicking on taskbar, losing
any other tabs which may have been open.  Not sure if this takes down all open
instances of Mozilla (separate windows on taskbar) or not.

Expected Results:  
Allow close button to function after "back" or "forward".
OR
Close print preview immediately after printing without relying on user.
(probably easiest to implement).

This is troublesome when printing a page while multiple tabs exist, because the
whole instance must be closed in order to get rid of the print preview view.  If
the remaining open tabs are not bookmarked, the user is out of luck.  It's very
tempting to use this navigation within print preview as a "feature" to print
multiple pages in a given history of links, but the feature uses its usefulness
when the user must close the browser to get rid of print preview mode.

I have a Samsung laser printer, but I doubt that's relevant.

(Sorry if this isn't critical, it does have the potential for lost data in other
tabs.  Still, critical seems a bit harsh.)
(Reporter)

Comment 1

16 years ago
Sorry, right-clicking after printing won't work, so no danger there to get
"back".  Alt-left, or clicking a fourth mouse button will still do it though.

Double sorry, loss of data can be averted by right-clicking on a link and
choosing "open in a new tab" which brings whole collection of tabs back.  Still,
print-preview menu-bar won't go away and regular menu bar does not appear to be
brought back.  Since it is probably not immediately obvious to the user that
this right-clicking to open a new tab can bring back the tabs, the potential for
easy data loss still exists.

Comment 2

16 years ago
Sounds simmilar to bug 177278. Could you try with the latest nightly build to
see if the bug is still present? If the nightlies scares you, you can wait for
1.3b which probably will be available soon.

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 177278 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.