'Static' Download-folder is not 'static' (but variable)

VERIFIED FIXED

Status

()

Toolkit
Downloads API
VERIFIED FIXED
15 years ago
10 years ago

People

(Reporter: Jake, Assigned: Blake Ross)

Tracking

({useless-UI})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030208 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030208 Phoenix/0.5

When I set the prefs to use one specific download folder it uses that folder on
the next download (so far so good). But when you use another dir once it will
use that dir for the next download as well. It seems to me like there is no
difference between "Ask me where to save every file" or "Save all files to this
Folder".

I know there is another bug about not being able to edit the folder in question,
but I believe this are 2 separate bugs.
The other bug is: 
http://bugzilla.mozilla.org/show_bug.cgi?id=178227

Reproducible: Always

Steps to Reproduce:
1. Download a file to the default dir
2. Download a file to another dir
3. Download a file to the 'new' default dir (it's now changed to the second dir)

Actual Results:  
In my opinion the 3th file is placed in the wrong dir.

Expected Results:  
At 3. the first dir should have been used (as that one is set manually as the
default dir)

Some kind of workaround:
place the following line in your user.js
user_pref("browser.download.dir", "X:\\Download Dir");

The default dir is now reset, but only once per session (better than never of
course).

Comment 1

15 years ago
Eeek! Good catch. Confirmed Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b)
Gecko/20030207 Phoenix/0.5

Phoenix resets the default download directory (pref browser.download.dir) when
you tell it to download somewhere else when the save dialog pops up (in fact,
I'm not even convinced that ought to be popping up unless there is already a
file of the same name in the default directory).

OS --> All
Status --> New

This may belong to the Preferences component but I'll leave it as a Downloading
problem.

Note: you can also reset the pref through about:config.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
(Reporter)

Comment 2

15 years ago
> (in fact, I'm not even convinced that ought to be popping up unless there
> is already a file of the same name in the default directory).

I'd prefer popping-up (but that's just me), so you can sort of use it as a
download manager (always in default dir, unless you specify otherwise).
But that's just my opinion I guess.

> Note: you can also reset the pref through about:config.

I know, but tnx anyway.

Comment 3

15 years ago
*** Bug 204510 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
Still happens with trunk build 20030726 (Linux).
Keywords: useless-UI
With the new download manager, if you specify a directory, it downloads without
prompting for a directory.  So the only way to save elsewhere is to switch back
to always ask.  That being said, is this still valid?
QA Contact: asa → mpconnor

Comment 6

15 years ago
I too think this bug was fixed with the landing of the new download
functionality. With build 20030810 on Linux this option now works as expected.

Marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Verified using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b)
Gecko/20030817 Mozilla Firebird/0.6.1+
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.