typing in location bar causes menus to be pulled down

VERIFIED WORKSFORME

Status

()

Core
Editor
P3
normal
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: Warren Harris, Assigned: saari (gone))

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Often when typing in the location bar, random menus just get pulled down for me.
It seems like there's a race condition or logic error in the event processing
code that causes the events to be interpreted as accelerator keys rather than
text entry events.

Comment 1

19 years ago
Warren -- are you using commercial or debug build? from which day? what
platform?

Updated

19 years ago
Assignee: beppe → saari

Comment 2

19 years ago
I think this is an xpfe issue, assigning to saari
(Reporter)

Comment 3

19 years ago
mozilla debug

Comment 4

19 years ago
This is almost certainly a DUPLICATE of bug 17749. If so, it's Event Handling.

How to tell:
1. ALT-TAB to the Mozilla window, click in Location Bar,
   type "f" - the File menu appears
2. ALT-TAB away from the Mozilla Window, ALT-TAB back.
3. Press and release the ALT key.
4. Click in Location Bar, type "f" - the File menu does not appear.

If what you see matches those four steps, this must be a DUP;
if what you are seeing does not match that pattern, please
add a comment to this bug saying so, and, if possible, with
a pattern that you have found, because in that case you've
probably found a new bug.

Assuming with OS:other and Platform:PC that the reporter's OS is Win98
(bug 16029).

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 5

19 years ago
This is not a dup of 17749 (no alt, no tab, no switching windows) but since it
isn't happening on any Tier-1 platform using today's opt comm bits, resolving as
wfm.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
verified in 12/15 build
You need to log in before you can comment on or make changes to this bug.