Java plugin fails to load on Mozilla startup

RESOLVED DUPLICATE of bug 189461

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 189461
16 years ago
16 years ago

People

(Reporter: Nisheeth Ranjan, Assigned: Peter Lubczynski)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I installed the JRE (version 1.4.1_01) on a fresh install of Redhat 8.0 and
created a symlink from the latest mozilla debug build's plugin directory into the 
libjavaplugin_oji.so shared lib.

But, when I run Mozilla, I get the following error dumped to the console:

LoadPlugin: failed to initialize shared library
/usr/java/j2re1.4.1_01/plugin/i386/ns610/libjavaplugin_oji.so
[/usr/java/j2re1.4.1_01/plugin/i386/ns610/libjavaplugin_oji.so: undefined
symbol: GetGlobalServiceManager__16nsServiceManagerPP17nsIServiceManager]
LoadPlugin() /usr/java/j2re1.4.1_01/plugin/i386/ns610/libjavaplugin_oji.so
returned 0

CCing a few linux hackers in the hopes that they can help...
(Reporter)

Updated

16 years ago
Blocks: 175358
(Reporter)

Updated

16 years ago
Blocks: 183092
(Reporter)

Comment 1

16 years ago
Seems like the plugin is calling GetGlobalServiceManager which lives in
nsServiceManagerObsolete.cpp?  So, this is either the plugin's fault for
exercising an obsolete API or Mozilla's fault for breaking backwards compatibility.

CCing some OJI/Java gurus...
nisheeth: 
Which Mozilla Build ?
Is this a self-compiled Build with Gcc3.2 (bug 116444)or an old build from the
last week (bug 189461) ?

Should be a dupe of bug 189461 but without build ID....
OS: Windows XP → Linux

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 189461 ***
No longer blocks: 175358, 183092
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.