Marquee doesn't work with two text styles

VERIFIED FIXED

Status

()

Core
Layout
--
major
VERIFIED FIXED
15 years ago
14 years ago

People

(Reporter: Toni SOUEID, Assigned: Doron Rosenberg (IBM))

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

at www.annaharonline.com and during newspaper closure days, they put a scrolling
text in arabic announcing this. The text is at the top of the page. In mozilla I
just see a blinking blue spot. In Internet Explorer it gets displayed well.

Reproducible: Always

Steps to Reproduce:
1. www.annaharonline.com on during newspapaer closure days
2. look at the top of the page to see a blinking blue line
3. this should be seen as scrolling text in IE

Actual Results:  
blinking blue line

Expected Results:  
scrolling text in arabic

Comment 1

15 years ago
can you attach a testcase ? Do you see any errors/warnings in JavaScript console ?

does it also happen with 1.3b ?

Comment 2

15 years ago
Not Bidi related. Testcase and explanation coming.
Assignee: mkaply → doron
Status: UNCONFIRMED → NEW
Component: BiDi Hebrew & Arabic → Browser-General
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 3

15 years ago
Created attachment 114096 [details]
Tetscase

The problem has to do with using two text modifers around marquee. In my case,
I am using <B> and <I>. On the page it is <FONT> and <B>
(Reporter)

Comment 4

15 years ago
> I've run the javascript console in 1.3a and i didn't
> see any errors/warnings.
> The problem persists in 1.3b.
> 
> Attached is a .zip file that gives you the saved page
> in case you would like to work on it offline along
> with two pictures showing how IE renders correctly and
> mozilla in a wrong way.
> 
> By the way the install script of 1.3b still proposes
> to install in directory c:\Program Files\mozilla1.3a.
> 
> Keep up the good work guys. I may one day join you
> when i finish my Computer Science diploma :)
> 
> Cordially,
> 
> Toni
(Reporter)

Comment 5

15 years ago
Created attachment 114146 [details]
the arabic web page that has problems

along with pics on how IE renders correctly and mozilla in a wrong way

Comment 6

15 years ago
As I already showed in my testcase, this has nothing to do with the Arabic on
the page.
Summary: scrolling arabic text problem → Marquee doesn't work with two text styles
(Assignee)

Comment 7

15 years ago
There is a marquee cleanup patch at
http://bugzilla.mozilla.org/show_bug.cgi?id=167224 that might fix it, I don't
have a build with it atm to test

Comment 8

15 years ago
*** Bug 200868 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
Setting major: Some text is not displayed at all. Kind of dataloss.

I try to find a better component: Layout for a start

Anyhow, I see the bug with those versions:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030331 (+ patch 101274)
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030421

pi
Severity: minor → major
Component: Browser-General → Layout

Comment 10

15 years ago
Created attachment 121280 [details]
Testcase

Better testcase.

pi
Attachment #114096 - Attachment is obsolete: true

Comment 11

15 years ago
Your new testcase doesn't fail for me whereas the old one does...

Comment 13

15 years ago
Ad comment 11: Michael explained by e-mail, it does work for him. Note: the
testcase shows failure in the first and success in the second and third example.

Ad comment 12: Let's wait until you fix for bug 167224 landed and see if it
solved this one.

pi
Keywords: testcase

Comment 14

15 years ago
http://www.championsgallery.com/ shows this behaviour as well.  Page has
<td><font><font><marquee> which results in the marquee failing to pick up a
width and being 1 pixel wide.

Having just looked at the xbl-marquee code and seen the problem that it's only
checking 2 parent elements rather than going back up the tree as far as
necessary, I see that the patch in bug 167224 will indeed fix this.
Depends on: 167224
(Assignee)

Comment 15

14 years ago
like I said, dupe. Now fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 16

14 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040421

Now it works. Marking VERIFIED.

pi
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.