Closed Bug 19268 Opened 20 years ago Closed 20 years ago

[DOGFOOD] Focus problem with iframe breaking Delete button in Mail

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mscott, Assigned: saari)

References

Details

(Whiteboard: [PDT+])

Using a release build for 11/18. The enabled / disabled status for the
delete button is working much better now. (That was another bug that
Paul helped fix).

But now, I find myself getting into frequent states where the delete button
doesn't work. That is, it appears to be enabled and I can click on it but
we aren't getting called to delete the message.


This usually happens after I've browsed and deleted a certain number
of messages.
I take part of that back. I actually am getting back into a state where
the delete button (and menu item) are disabled which is preventing me
from deleting messages.
I am definitely seeing the delete button become permanently disabled as soon as
I click a link in the message body. mscott: this is without your URL
dispatching turned on.
QA Contact: lchiang → esther
Sounds like we are seeing a focus issue, adding Chris Saari to see if he can

gather enough info from this bug to help us out.
Whiteboard: [PDT+]
putting on PDT radar
Status: NEW → ASSIGNED
Target Milestone: M12
Assignee: hangas → saari
Status: ASSIGNED → NEW
Summary: [DOGFOOD] Still having problems with the delete button → [DOGFOOD] Focus problem with iframe breaking Delete button in Mail
Sending to Saari.  Changing summary from "Still having problems with the delete
button" to "Focus problem with iframe breaking Delete button in Mail".  The real
problem we are seeing is that when a link is clicked on in a mail message in the
mail 3 pane view, the focus changes to the iframe showing the mail message but
the :focus did not get removed from the tree so it looks like the thread pane
still has focus.  In addition, when clicking on white space in a message the
focus does not move to the iframe but instead remains on the previously focused
widget.
Status: NEW → ASSIGNED
Whiteboard: [PDT+] → [PDT+] 11/26
*** Bug 19925 has been marked as a duplicate of this bug. ***
Whiteboard: [PDT+] 11/26 → [PDT+] 12/1
I'm working on a set of fixes for focus/blur events, but I need to confer with
editor folks.
Whiteboard: [PDT+] 12/1 → [PDT+] 12/1 Need to talk to editor guys
OS: other → All
Hardware: PC → All
Using Linux redhat 6.0 and Win_nt 4.0 (1999-12-01-09 M12)
Mac (1999-12-01-08 M12)
I have seen this problem occurred on all 3 platforms. So change to ALL
platforms.
Whiteboard: [PDT+] 12/1 Need to talk to editor guys → [PDT+] 12/3
Blocks: 20870
*** Bug 21159 has been marked as a duplicate of this bug. ***
This is fixed now
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Chris, did this really work for you in mail?

This is still a problem for me using today's 12/09 release build. Re-opening.
I take it back. I may have pre-maturely re-opened this. When I click on a link
in a mail message, it loads in the browser window. However, to re-enable the
delete button I still ahave to click in the thread pane to restore focus to the
thread pane instead of the message pane.

This may just be the expected behavior although in 4.5 I'm pretty sure clickin
on a link the message pane didn't actually steal focus from the thread pane.
Fixing that part of the problem probably isn't PDT+ though.
No I take back what I said earlier...I'm still getting into a stuck state where
the only way to get the delete button re-enabled is to click back on teh folder
pane and then back to the thread pane.
Whiteboard: [PDT+] 12/3 → [PDT+] 12/9
Huh, I could have swore this worked... what platform did you try on?
Clearing Fixed resolution due to reopen.

All - please indicate which builds you are using.  This can help communication
on who is seeing what where.  Thanks!
hey chris...i was using the windows commercial build. I think I've almost put my
finger on it. I think it happens now when I view a message, then I scroll
through the message body (which is in an iframe). Then I move back up and hit
the delete button to delete the message.

When I move the cusor out of the message window, the blue line in the THREAD
pane becomes disabled and then the delete button becomes disabled. I have to
clik on the folder pane then back to the thread pane in order to get the delete
button back.

So I think the problem is: reading the message, scrolling through it, then you
want to delete it.
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen.
mscott, thanks for the additional info, it makes all the difference!

Scrollbars don't have user-focus: ignore set in their CSS. Dollars to doughnuts
says that will fix the problem...
I just checked in the scrollbar css to prevent stealing of focus, but I can't
get mail to work for me.

mscott, can you pull global.css and tell me if this is fixed?
Whiteboard: [PDT+] 12/9 → [PDT+] 12/9 Potentially fixed now
Hey Chris, so I have a tree from yesterday morning and I just pulled the one
global.css file to pick up your change. Things are definetly better. But
something still isn't quite right. I can't put my finger on it. When I scroll
through the message body, I see the delete button still get disabled. I have to
click on the message in the thread pane again to force focus change which allows
the delete button to get re-enabled.

Maybe this will make it more clear, here's my useage pattern:
1) Click on a message in the thread pane to read it
2) scroll through the message body to read it
3) now I want to delete the msg but the delete button is disabled so go
re-click on the msg in the thread pane
4) and then hit the delete button.
Whiteboard: [PDT+] 12/9 Potentially fixed now → [PDT+] 1210 Working on it
Ok, I finally got mail working for me (yeay! Ouch, slow!)

So I see the problem... Hrm. Looks like the css rule did do what I expected it
to. How annoying.
The case that mscott mentioned in his comments dated today at 10:48am is covered
under http://bugzilla.mozilla.org/show_bug.cgi?id=21151.
Whiteboard: [PDT+] 1210 Working on it → [PDT+] 1210 fix waiting to checkin
I have a fix waiting in the wings. Smack CSS a little harder, and it works.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+] 1210 fix waiting to checkin → [PDT+]
Fix checked in
Blocks: 21564
Status: RESOLVED → VERIFIED
Using build 1999121309m12 on win98 and build 1999121308m12 on mac and linux this
is fixed.  Verified
thanks for fixing this, yes this is much better now.
No longer blocks: 20870
No longer blocks: 21564
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.