Buttons drawn incorrectly (Stylesheet problem?)

RESOLVED DUPLICATE of bug 194934

Status

()

P2
normal
RESOLVED DUPLICATE of bug 194934
16 years ago
5 years ago

People

(Reporter: fredrik.tobisson, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030210

Some of the buttons to choose system (Pro/Plus, Windows etc...) are missing, or
drawn in incorrect places and shapes. I noticed it first with this new 1.3b (not
earlier (nightly) builds of 1.3b). Internet Explorer also draws the page correctly.

Reproducible: Always

Steps to Reproduce:
1. Go in to the above mentioned page


Actual Results:  
Some of the buttons are drawn incorrectly or are missing. The actual links
(image maps?) are there, as can be seen in the status bar at lower left. There
are holes in the row of buttons, and at least one of the buttons is dran to the
far right end of the horizontal bar

Expected Results:  
Drawn the buttons correctly. Do I need to expand on this?
WFM, Win32, latest trunk build.
worksforme, linux trunk build 2003-02-11-08
(Reporter)

Comment 3

16 years ago
Now I can't replicate the problem. When I had the problem, I tried to get rid of
it by different combinations of emptying cache and reloading the page. It did
not help.

Later, I got a problem where Mozilla did not behave correcly when clicking on a
link in one frame with a target in another. (The page in the target frame was
sent to the frame in which the link I was clicking was, instead of sending the
page the link was refering to the target frame. Or, in other words, the page was
divided in left and right frame. If I clicked a link in the left frame, the
contents of the right frame now also was displayed in the left frame. What i
expected was that a completely other page would be displayed in the right frame,
and the contents of the left frame should be unchanged.

Again, I emptied cache. But now I also quit Mozilla, and started it again, and
thereafter reloaded the page. Then it worked as it should.

That made me think that maybe my problem with versiontracker had gone away. And
yes it had.

So I guess that I had some kind of random errors in Mozilla. I know that I did
quit Mozilla between the first and the second error. Unfortunately, I can't
replicate them now, but Mozilla 1.3b for Mac OS X does not feel as a wonder of
stability... Can somebody tell me if there is a log fle or similar that can be
used for error tracking?
(Reporter)

Comment 4

16 years ago
Created attachment 114536 [details]
This is an example of how it looks when the buttons are drawn incorrectly
(Reporter)

Comment 5

16 years ago
Created attachment 114542 [details]
Another example. Note the row of Pro/Plus buttons in completely wrong place

Comment 6

16 years ago
WFM 1.3b / OS X

Fredrik, is this happening again or are those new screenshots old?
Component: Browser-General → Layout

Comment 7

16 years ago
oops... really reassinging
Assignee: asa → other
QA Contact: asa → ian
(Reporter)

Comment 8

16 years ago
Created attachment 114576 [details]
Third example. Now there seems to be a ne column, in front of the program listing.

I've experimented a bit, and I can't get rid of this strange behaviour. I have
cleared disk cache, restarted Mozilla, reloaded te page. Nothing helps. I
haven't restarted my computer, that remains to be tested.
(Reporter)

Comment 9

16 years ago
Reply to Chris Casciano: They are new, but similar to what happened the first
time, urging me to report this bug. Well, except for the third example, which I
did not experience the first time. It is to some extent similar to what happened
to me as described in the 3rd comment (the slightly delirious frame discussion).

Comment 10

16 years ago
marking new... didn't catch any dupes when i looked
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: DUPEME
(Reporter)

Comment 11

16 years ago
I've had a suspicion that it has something to do with reload. I went into
Versiontracker just now, it was a while since. Furthermore, it was just after 7
PM CET, which means around noon American time, with congestion on the net. The
"buttons" were drawn correctly, but it took ages for the page or Mozilla to
finish. In fact, I interrupted (stopped) Mozilla before it was finished (I could
not see what was not finished, and I couldn't wait any longer). And then, the
"buttons" were all over the place again.

Updated

16 years ago
Priority: -- → P2

Comment 12

16 years ago
duping to 194934 which is assigned & has a more accurate description of the problem

*** This bug has been marked as a duplicate of 194934 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.