Can't cancel software installation when downloading a theme

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
16 years ago
10 years ago

People

(Reporter: lrivers, Assigned: andreww)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030210

Downloading the aquamoz theme from deskmod
Apparently, the installer couldn't find the theme, so it never actually started
the download
the "software installation" window appears, but clicking "cancel" does nothing
Must quit Mozilla

Reproducible: Always

Steps to Reproduce:
1. Attempt to download a theme with a bad url
2. the "software installation" window appears, but 
3. clicking "cancel" does nothing

Actual Results:  
window not dismissed

Expected Results:  
window dismissed, download attempt stops

Comment 1

16 years ago
WorksForMe using FizzillaMach/2003022103. AquaMoz download/installation does
begin, and Cancel works as expected.

Lorin, can you still reproduce this problem using a current nightly build? If
so, can you reproduce this problem using another Mozilla user profile?

Comment 2

16 years ago
Reporter, XPI installs were very broke on OS X until very recently, can you
download a nightly build and see if you're still having a problem with (a) the
cancel button and (b) the theme install?
Blocks: 197105
(Reporter)

Comment 3

16 years ago
Seems better, though I crashed while testing this fix:
Begin to download, cancel, re-download same theme, crash
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 4

16 years ago
hmm... crash.... bad... i'm going to reopen for the moment until that can be
tracked down (or the blame can be put on a different bug)

When you crashed did talkback popup, and if so do you have a talkback id?
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 5

16 years ago
multiple visits to the following url & install attempts isn't crashing me...

http://www.deskmod.com/?show=showskin&skin_id=22317&install=true

20030326 Trunk build

Lorin, a talkback id or crash log
(~/Library/Logs/CrashReporter/mozilla-bin.clrash.log) would be wonderful
(Reporter)

Comment 6

16 years ago
TB216313X is the Talkback ID.

Hope it helps!
(Reporter)

Comment 7

16 years ago
The crash thing should probably be a new bug...

Comment 8

16 years ago
Yes, please file the crash as a separate bug.

Comment 9

16 years ago
bug 199793 filed on the crash (i was waiting to look at the stack trace to see
it its just a dupe of one of the other outstanding XPI bugs but didn't get
around to bugging anyone for it)... resolving this as WFM per comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 10

16 years ago
wfm 4/18 build
Status: RESOLVED → VERIFIED
QA Contact: pmac → gbush
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.