If you create a file with a semicolon in the filename, it does not handle the save correctly.

RESOLVED DUPLICATE of bug 192765

Status

SeaMonkey
Composer
RESOLVED DUPLICATE of bug 192765
15 years ago
13 years ago

People

(Reporter: Brad Silva, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

(From composer) If you create a file with the name "test;bad.html", it will
create the file and save the data.  However, subsequent saves produce the file
"test".  

Furthermore, if you are working on two files: "test;bad.html" and
"test;verybad.html", each save will overwrite the file "test" with no warning.

Suggest

Reproducible: Always

Steps to Reproduce:
1.See details.
2.
3.

Actual Results:  
See details.

Expected Results:  
Either complained about the semicolon in the filename (preffered).  Or,
correctly created the file.

I strongly suggest you disallow the semicolon in filenames.  It can be done, but
it will also cause problems with shell scripts, etc, that try to manipulate the
file.

Thanks,
Brad

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 192765 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.