Changing home directory distroys profile?

VERIFIED DUPLICATE of bug 22689

Status

SeaMonkey
Startup & Profiles
--
major
VERIFIED DUPLICATE of bug 22689
16 years ago
14 years ago

People

(Reporter: Aaron Vose, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

When I changed my home dir (and copied ALL my files) mozilla could not find my
profile.  The name of my profile appears in the list, but when I select it,
mozilla says my profile cannot be found.  Mozilla really needs a better way to
manage profiles.  When mozilla complained that a profile was missing, It gave me
three options (None of them usefull in my case): "New Profile", "Remove
Profile", and "Rename Profile".  Why not "Add" or "Edit"? Needs some work yo!

Reproducible: Always

Steps to Reproduce:
1. Create profile.
2. Change home directory.
3. Try to get mozilla to use your profile by using the GUI that will pop up when
you run it next.

Actual Results:  
The mozilla GUI appeared asking me to select a profile.  The name of my profile
shows up in the list.  When I select it, an error window appears saying it
cannot find my profile.  There is no option to tell mozilla that the profile has
moved.

Expected Results:  
It should have an "Edit" Option to let me select the location (file name) of my
profile since mozilla cound not find it.

Comment 1

16 years ago
there's a bug about the fact that profiles don't store relative paths.
there's a bug about moving profiles.
i believe there's a bug about changing where a profile points.
there's definitely a bug about importing a profile.
Whiteboard: DUPEME

Comment 2

16 years ago
May be duplicate of one of import enhancement requests- 
bug 17457, bug 22689, bug 87145

I think bug 22689 fits here

relative path bug is bug 12911- which is verified but needs bug 137006 for
completion by mail


*** This bug has been marked as a duplicate of 22689 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.