Posts to ignored threads sometimes fail to be marked read

RESOLVED WORKSFORME

Status

MailNews Core
Networking: NNTP
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Stewart Gordon, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2) Gecko/20021126

This seems to happen mostly on the SpamCop newsgroups (news.spamcop.net server)
for some reason.  When everything seems to be marked read, it still shows a
number of unread messages.  Are they headers waiting to be downloaded?  No,
they're ignored posts that have slipped past the mechanism to automatically mark
them read.

Reproducible: Sometimes

Steps to Reproduce:
1. Open a newsgroup that has unread messages.
2. In Threads with Unread view, go through all the remaining unread threads
ignoring them.
3. Press Get Msg.
4. Realise that's not the problem, so set view to Unread, Ignored Threads.

Actual Results:  
1. Newsgroup opens normally.
2. Once this is done, the newsgroup list still indicates unread messages.
3. No new messages in newsgroup, so unread count remains the same.
4. I see some unread, ignored threads.


Expected Results:  
Already marked the posts to ignored threads as read when they came in, as it
does normally.
(Reporter)

Comment 1

16 years ago
Should've said "Open a newsgroup that has unread messages and ignored threads".
 But I guess that's kind of obvious.
(Reporter)

Comment 2

15 years ago
One of my 'groups had 1160 or so unread messages when I came in today.  When I
opened it and downloaded the headers, it cut down the count to 570 or so.  But
then I had to kill Mozilla thanks to bug 223597 again and not having time to
wait.  And of course, since a force quit loses all unread/read status
information (I can't seem to find a bug number for this), the count was back to
1160 or so on restart.

Bit since the headers were already downloaded, they hadn't re-passed through the
ignored -> read filter.  So this is probably one cause of this problem.  But I'm
sure it's not the only cause.
Summary: posts to ignored threads sometimes fail to be marked read → Posts to ignored threads sometimes fail to be marked read

Updated

14 years ago
Blocks: 236849
Product: MailNews → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 4

13 years ago
Still happening - 2005092710
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Comment 6

11 years ago
WFM version 2.0.0.6 (20070728)
please reopen if you see otherwise
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
No longer blocks: 236849
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.