message could not be sent because connecting to SMTP server failed



MailNews Core
Networking: SMTP
15 years ago
9 years ago


(Reporter: Pascal Rocq, Assigned: Scott MacGregor)


Windows 2000

Firefox Tracking Flags

(Not tracked)



(3 attachments)



15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

When i try to send a message, it don't work. It worked fine with rev 1.3a(no 
change in the config).
I tried to create a new profil with only the smtp server (no pop or imap 
server) and the results are the same: fine with 1.3a, error with 1.3b

Reproducible: Always

Steps to Reproduce:
1.configure SMTP server ( for me)
2.compose a message
3.clic on send

Actual Results:  
error message appears instantly:
Sending of message failed.
The message could not be sent because connecting to SMTP server mail-france- failed. The server may be unavailable........etc

Expected Results:  
sending of message

The first time i tried with 1.3b, i got the error and i looked in the 
preferences. The port number in the SMTP server configuration screen where 
empty. I filled it with the correct number (25) but it still dont worked.

When i install rev 1.3a it works, when i install rev 1.3b it don't work, When i 
install rev 1.3a it works, when i install rev 1.3b it don't work .... and so on 
(and absolutly no change of the preferences between each try)

Comment 1

15 years ago
Do you have access to a different smtp server?  Can anyone suggest one (e-mail
it to the reporter)?

Comment 2

15 years ago
Created attachment 114315 [details]
This is the preferences file of the profile used to test.

Comment 3

15 years ago
I do not have access to another SMTP server because I am behind a firewall. I
can't read my personal mails with a mail reader from my office.
At home I have an iMac which runs Mac OS X 10.2.3
On it I alternatively use Mozilla, Chimera and Safari for browsing , but i do
not use the mail client of mozilla. But I will try soon.

Comment 4

15 years ago
I get the same problem, running 1.3b in Windows XP.
(Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210)

The settings for my mailserver ( are correct--they match those that
I have set up in Outlook Express, and sending a message with that works fine. 
Mozmail keeps giving the error "Sending of message failed."  Reverting back to
1.3a fixes the problem.

The only thing that looks odd to me is that in the Advanced menu for the
Outgoing SMTP server there are apparently two entries for my SMTP server, and
both of them are labeled as Default, so I cannot remove either of them.

Comment 5

15 years ago
I just upgraded to 1.3 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3)
Gecko/20030312), and the problem still exists (sending to SMTP server  I tried a different mail server ( and I could send
fine.  I can't use the mail server since I'm no longer part of that
domain, and can only send to addresses with that domain.  

The problem leads me to believe that my mailserver is broken, or Mozilla Mail
doesn't like it. Is there any way to log the SMTP connection?  That would
probably help me figure out what's going wrong...

Comment 6

15 years ago
Created attachment 117233 [details]
SMTP log showing problem

This is the SMTP log for when I try to send mail from Mozilla.	It appears that
MozMail is resetting to the initial state and not recognizing the responses
from my mail server.  Notice that each response from the mail server is
terminated by a ^M character;  that may be what's causing the problem.

Comment 7

15 years ago
Created attachment 117235 [details]
SMTP log of healthy connection (from 1.3a)

This shows that the sever ( does indeed work under 1.3a (Windows;
U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212)
Product: MailNews → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.