URL+anchor opened in background tab don't scroll to anchor

VERIFIED DUPLICATE of bug 279844

Status

Camino Graveyard
Tabbed Browsing
--
minor
VERIFIED DUPLICATE of bug 279844
15 years ago
13 years ago

People

(Reporter: Scott Houchin, Assigned: Brian Ryner (not reading))

Tracking

unspecified
Camino1.0
PowerPC
Mac OS X

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030210 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030210 Chimera/0.6+

When I open several new tabs that are to anchors in a page and not the top of
the page, Chimera always loses that scroll position when I switch between tabs
and appears to put me at the scroll position of the previous tab

Reproducible: Always

Steps to Reproduce:
1. Open a page that contains links to anchors. A good choice is
www.macintouch.com, where you can always click on the links to the newest
updates in the reader reports at the top of the main page.
2. Open several new tabs to those anchors
3. Switch between tabs. Not one of those new tabs will be scrolled to the anchor
point

Actual Results:  
Scroll position on the new tabs is incorrect

Expected Results:  
Each tab should be scrolled to the correct anchor. I think this may be a mor
general problem where scroll position is not kept for each individual tab, but
for the window as a whole

Comment 1

15 years ago
WorksForMe using Chimera/2003021707. With two tabs open to anchored URLs,
switching between them doesn't change the scroll position. Scott, can you still
reproduce this problem using a current nightly build?
(Reporter)

Comment 2

15 years ago
I just tried visiting macintouch.com with Chimera/2003022108, and the problem
still occurs. I may have not described the problem correctly.

I opened five tabs from that page, each of which go to an anchor. I did not
visit any of the tabs until all five had opened. Not one of those tabs was
scrolled to the anchor point. In fact, one of them was scrolled to wll past the
bottom of the actual content.

Here are the tabs I visited:
http://www.macintouch.com/cinemadisplays02.html#feb21
http://www.macintouch.com/icheap02.html#feb21
http://www.macintouch.com/idvdpart02.html#feb21
http://www.macintouch.com/iphoto7.html#feb21
http://www.macintouch.com/wirelesslanreader15.html#feb21

Once I got to those pages, scrolling in one tab was not affected by the other
tabs, but I had to manually adjust the scroll position in each tab upon opening
to find the anchor.

Comment 3

15 years ago
So, you have tabs set to open in the background? Is that setting significant to
the problem?
(Reporter)

Comment 4

15 years ago
Ah yes, it does appear to be linked to opening tabs in the background. When I
turned off that option and opened those five pages as new tabs from this
bugzilla page, all of the pages opened to the correct point

Comment 5

15 years ago
Confirmed using Chimera/2003021707.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Scroll position not maintained for each tab → Tabs opened to URL+anchor in background don't scroll to anchor

Comment 6

15 years ago
Still a problem with Camino/20030509.

Just noting that I use this background-tab-loading feature heavily, and would
like to vote to see this bug fixed.
-> bryner
Assignee: pinkerton → bryner
Still present in 2003082402.

Comment 9

15 years ago
*** Bug 197245 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
Shock horror -- I've found an already-filed bug for a bug I was going to report!
Still present in 2003121003.

Comment 11

14 years ago
dupe of bug 157282? 
I found the same problem on Galeon only when "file" scheme access.

This bug is not specific to Camino, maybe specific to all other embedding browser.

I guess this bug happens when the completion of the page loading is faster than
size allocation of the widget.

still present in 2004090408 (v0.8+)

Comment 14

14 years ago
Still present with 2004092608 NB (trunk).
Summary: Tabs opened to URL+anchor in background don't scroll to anchor → URL+anchor opened in background tab don't scroll to anchor
Target Milestone: --- → Camino1.0

Comment 15

14 years ago
Oddly there is ONE site that works for me regarding this issue:
http://www.xlr8yourmac.com/
I use to go to single home page postings from links in a Bloglines page and I
always land to the right place.
All other sites I'm using confirm the bug.

Comment 16

13 years ago
(In reply to comment #15)
> Oddly there is ONE site that works for me regarding this issue:
> http://www.xlr8yourmac.com/
> I use to go to single home page postings from links in a Bloglines page and I
> always land to the right place.
> All other sites I'm using confirm the bug.

That site seems to exhibit the bug to me.  I don't know what you're doing
differently.

(I just checked things out in build 2005011508)

Anyhow, If it matters, an interesting thing to do is to load the tabs in the
background, and then go to each one and reload it from the url bar and watch how
much it jumps.  For example, at
http://w3.org/Style/CSS/current-work
if you open any of the links on the right in tabs in the background, (with the
exception of "CSS home" which doesn't point to an anchor, and "Test suites"
which seems not to do it since it's at the bottom of the page), the page doesn't
load anywhere near the anchor.

I'd really like to see this fixed soon!
Bug 279844, while more recent, has a patch under review...

*** This bug has been marked as a duplicate of 279844 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.