style attribute of dynamically added xul element not applied

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Jean-Pierre Matsumoto, Assigned: David Hyatt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021203
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021203

If you append a new element (created with method createElement, appended with
method appendChild) with a style attribute (defined with method setAttribute) to
a XUL document, style attribute is not applied.

But there is a stange behavior : if you apply setAttribute after appending, it
works well !?

Reproducible: Always

Steps to Reproduce:
1. open index.html (attachment 'repporter test case')
2. click on 'test before append XUL'

Actual Results:  
There is no yellow box.


Expected Results:  
There should be a yellow box, as for 'test after append XUL' or 'test before
append HTML'

Workarond is not easy because it's not natural to set style attribute after
appending and it prevents some code encapsulation.
(Reporter)

Comment 1

15 years ago
Created attachment 114214 [details]
index for test case
(Reporter)

Comment 2

15 years ago
Created attachment 114215 [details]
test before appending (XUL)
(Reporter)

Comment 3

15 years ago
Created attachment 114216 [details]
test after appending (XUL)
(Reporter)

Comment 4

15 years ago
Created attachment 114217 [details]
test before appending (HTML)
(Reporter)

Updated

15 years ago
Attachment #114217 - Attachment description: test befor appending (HTML) → test before appending (HTML)
(Reporter)

Comment 5

15 years ago
Created attachment 114218 [details]
index for test case

with working links
Attachment #114214 - Attachment is obsolete: true
This worksforme in Linux trunk build 2004-01-09-07.  Probably fixed by the patch
in bug 7639.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.