trunk topcrash [@ CSSStyleSheetImpl::SetEnabled]

VERIFIED FIXED in mozilla1.3final

Status

()

Core
CSS Parsing and Computation
P2
critical
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: Jan Carpenter, Assigned: bz)

Tracking

({crash, topcrash})

Trunk
mozilla1.3final
x86
Windows 2000
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

16 years ago
This stack signature is a trunk topcrash

STACK TRACE:
Source File :
c:/builds/seamonkey/mozilla/content/html/style/src/nsCSSStyleSheet.cpp line : 2033
 
====================================================================================================
     Count   Offset    Real Signature
[ 3   CSSStyleSheetImpl::SetEnabled 58fb9795 - CSSStyleSheetImpl::SetEnabled ]
 
     Crash date range: 2003-02-09 to 2003-02-11
     Min/Max Seconds since last crash: 104013 - 268022
     Min/Max Runtime: 104013 - 280442
 
     Count   Platform List 
     1   Windows NT 5.1 build 2600
     1   Windows NT 5.0 build 2195
     1   Windows NT 4.0 build 1381
 
     Count   Build Id List 
     1   2003020708
     1   2003020508
     1   2003020208
 
     No of Unique Users         3
 
 Stack trace(Frame) 

	 CSSStyleSheetImpl::SetEnabled
[c:/builds/seamonkey/mozilla/content/html/style/src/nsCSSStyleSheet.cpp  line 2033] 
	 CSSLoaderImpl::PrepareSheet
[c:/builds/seamonkey/mozilla/content/html/style/src/nsCSSLoader.cpp  line 1352] 
	 CSSLoaderImpl::InternalLoadAgentSheet
[c:/builds/seamonkey/mozilla/content/html/style/src/nsCSSLoader.cpp  line 2119] 
	 CSSLoaderImpl::LoadAgentSheet
[c:/builds/seamonkey/mozilla/content/html/style/src/nsCSSLoader.cpp  line 2082] 
	 nsHTMLEditor::AddOverrideStyleSheet
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsHTMLEditor.cpp  line 3623] 
	 XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp 
line 102] 
	 XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp  line 2025] 
	 XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp 
line 1293] 
	 js_Invoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 841] 
	 js_Interpret	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 2804] 
	 js_Invoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 857] 
	 nsXPCWrappedJSClass::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp  line 1199] 
	 nsXPCWrappedJS::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp  line 429] 
	 PrepareAndDispatch
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp 
line 117] 
	 SharedStub
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp 
line 139] 
	 nsCommandManager::CommandStatusChanged
[c:/builds/seamonkey/mozilla/embedding/components/commandhandler/src/nsCommandManager.cpp
 line 118] 
	 nsComposerCommandsUpdater::UpdateOneCommand
[c:/builds/seamonkey/mozilla/editor/composer/src/nsComposerCommandsUpdater.cpp 
line 362] 
	 nsComposerCommandsUpdater::NotifyDocumentCreated
[c:/builds/seamonkey/mozilla/editor/composer/src/nsComposerCommandsUpdater.cpp 
line 67] 
	 nsEditor::NotifyDocumentListeners
[c:/builds/seamonkey/mozilla/editor/libeditor/base/nsEditor.cpp  line 2616] 
	 nsEditor::PostCreate
[c:/builds/seamonkey/mozilla/editor/libeditor/base/nsEditor.cpp  line 340] 
	 nsHTMLEditor::PostCreate
[c:/builds/seamonkey/mozilla/editor/libeditor/html/nsHTMLEditor.cpp  line 345] 
	 nsEditingSession::SetupEditorOnWindow
[c:/builds/seamonkey/mozilla/editor/composer/src/nsEditingSession.cpp  line 472] 
	 nsEditingSession::EndDocumentLoad
[c:/builds/seamonkey/mozilla/editor/composer/src/nsEditingSession.cpp  line 908] 
	 nsEditingSession::OnStateChange
[c:/builds/seamonkey/mozilla/editor/composer/src/nsEditingSession.cpp  line 696] 
	 nsDocLoaderImpl::FireOnStateChange
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp  line 1213] 
	 nsDocLoaderImpl::doStopDocumentLoad
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp  line 867] 
	 nsDocLoaderImpl::DocLoaderIsEmpty
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp  line 765] 
	 nsDocLoaderImpl::OnStopRequest
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp  line 695] 
	 nsLoadGroup::RemoveRequest
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsLoadGroup.cpp  line 703] 
	 nsInputStreamChannel::OnStopRequest
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsInputStreamChannel.cpp  line 357] 
	 nsCOMPtr_base::assign_with_AddRef
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp  line 70] 
	 nsInputStreamPump::OnStateStop
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsInputStreamPump.cpp  line 468] 
	 nsInputStreamPump::OnInputStreamReady
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsInputStreamPump.cpp  line 321]  


URLs\COMMENTS:
     (17100164)	Comments: Was reading news  then read email. after reading the
last of the new mail  I deleted it (one mail message) and got a dialog saying 
something like  'Do you want to go to comp.lang.perl.tk?' I pressed cancel and
mozilla boinked.     Side note: this is a
     (17100164)	Comments:  Dell 8000 that had been on standby all night.
     (17057329)	URL: irc.opennode.net
     (17057329)	Comments: I clicked on close for a compose window that was appearing
->bzbarsky
Assignee: dbaron → bzbarsky

Updated

16 years ago
Severity: normal → critical
This is almost certainly caused by bug 167415 -- I bet we clone out a stale
mDocument pointer.... See bug 167415 comment 0 and bug 167415 comment 4.
Depends on: 167415
Priority: -- → P2
Target Milestone: --- → mozilla1.3final
fixed by checkin for bug 167415 on trunk.  Will be fixed on branch once I get
driver approval....
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 4

15 years ago
based on the verification of bug 167415, verifying this bug, as well.
Status: RESOLVED → VERIFIED
Crash Signature: [@ CSSStyleSheetImpl::SetEnabled]
You need to log in before you can comment on or make changes to this bug.