Status

()

enhancement
P3
normal
RESOLVED WONTFIX
17 years ago
5 years ago

People

(Reporter: clahey, Assigned: blizzard)

Tracking

Trunk
mozilla1.8beta1
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
User-Agent:       Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030128
Build Identifier: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030128

I would like to add a new printing backend to mozilla which uses gnome print to
render.  This would allow full support of all options in gnome's print dialog
and would support gnome's native print preview.

Reproducible: Always

Steps to Reproduce:
1. Choose print from menus.
Actual Results:  
xul print diaog

Expected Results:  
native print dialog

Updated

17 years ago
Blocks: 193001

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Comment 1

17 years ago
Ah, these steps to reproduce are for 193001, not for this bug.  The user visible
affects of this bug are that the output will better match what was requested in
gnome's native print dialog.
Assignee

Updated

17 years ago
Blocks: gtk2
Assignee

Comment 2

17 years ago
Is there any advantage to using gnome-print for printing as opposed to just
improving the PS module that we already have in the tree?
Reporter

Comment 3

17 years ago
There are a couple of things.

Firstly, this would allow us to use gnomeprint's native print preview dialog to
make it better match with other gnome apps.

Secondly, gnome print's dialog allows the user to set a number of features like
4 on a page or different layouts of logical pages per physical page.  To my
knowledge, mozilla's ps printing doesn't support these features, and gnome print
doesn't support these features if all you give it is ps output.
Reporter

Comment 4

17 years ago
Also, the gnome-print backend's support for reading a ps file is a bit of a hack
and in general, it doesn't have as good support as using gnome-print's rendering
code.  An example of this is that the gnome-print pdf output doesn't support
reading in a ps file.
Assignee

Comment 5

17 years ago
Is there an API reference out there that we can use?  I just loathe adding yet
_another_ freaking gfx port.
Reporter

Comment 6

17 years ago
I don't know how good the API reference is.  I often tend to not read references
and just read the code.

I wasn't expecting you to add this.  I'm willing to work on this, but I don't
know the mozilla code base well so I don't know where to start.

Updated

17 years ago
Blocks: 98995
Priority: -- → P3
Target Milestone: --- → Future

Comment 7

15 years ago
I'm not sure how this can work. I suppose gnome-print knows nothing about html.
That seems to imply that we have to use a very lower-level APIs of gnome-print
after doing most of things ourselves. If that's the case, there doesn't seem to
be a huge advantage here. Not familiar with gnome-print, I could be totally wrong.

Anyway, Chris, if you're willing to work on this, why don't you assign this to
yourself? You can take a look in gfx/src/ps, gfx/src/gtk, and gfx/public.


Assignee

Comment 8

15 years ago
Owen has been making serious noises about printing with pango.  I'm going to try
and sit down with him and find out what his plans are and try and make use of
his work.

Comment 9

15 years ago
blizzard, can we assign this one to you then?
Assignee: rods → nobody

Comment 10

15 years ago
blizzard, is what Owen has been pondering over similar to 'PangoPDF' I mentioned
to you last year ? 
http://www.geocrawler.com/archives/3/522/2003/3/0/10368570/

We might end up adding yet another gtk port, but if it can give better result
than two (yet-to-be-implemented) alternatives discussed in bug 211763 and bug
190031. (see also bug 219682 and bug 234182), there's not much to fear :-)
Owen and I sat down and talked about what he's planning on doing and what we
should probably be doing over the long term.  In the short term what he's going
to be doing with gnomeprint and pango is probably not going to be that useful
unless Mozilla is using gnomeprint for all of its printing primitives.  That is,
of course, a possibility, but a somewhat painful one since it means writing Yet
Another Backend, something which I am loathe to do.

However, in the short term we've got more options related to using pango for
glyph rendering.  Owen and I have a date next week to sit down and go through
your patch and figure out what to do with that patch as well as thinking about
how to use it in such a way as it increases the quality of Mozilla's current
postscript rendering code.

Updated

15 years ago
Target Milestone: Future → mozilla1.8beta

Updated

15 years ago
Assignee: nobody → blizzard

Comment 12

12 years ago
As I understand it, gnomeprint is currently viewed as deprecated. A new project would be better off targeting the GTK+ printing system which is viewed as replacing Gnomeprint.
As comment #12 already says it: Shouldn't this bug be closed as WONTFIX as gnomeprint has been deprecated?
Yep, we use cairo and the native print dialog now.  Marking WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.