Pasting content from AOL8 results in too small of a font on some browsers

VERIFIED INVALID

Status

()

Core
Editor
P1
normal
VERIFIED INVALID
16 years ago
15 years ago

People

(Reporter: Kevin McCluskey (gone), Assigned: Joe Francis)

Tracking

({topembed+})

Trunk
mozilla1.4alpha
topembed+
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE+)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
AOL8 wraps blocks of text with <font face="arial,helvetica"><font size="2"
family="SANSSERIF" face="Arial" lang="0">.  

The gecko:editor uses <small> elements to change the font size.  

Due to a bug in older versions of IE, text which is contained within a
combination of a <font size = 2> and <small> elements renders too small. (IE 6
does not have this bug)

Proposal:

Strip off the <font> element when pasting content from AOL8.0, substituting some
markup that the gecko:editor understands and is also compatible with older
version of IE.
(Reporter)

Updated

16 years ago
Keywords: topembed
Priority: -- → P1
Whiteboard: EDITORBASE
Target Milestone: --- → mozilla1.4alpha
(Reporter)

Comment 1

16 years ago
Created attachment 114240 [details]
test case from Dave Barrowman

Comment 2

16 years ago
I think it should be all platforms since we can see this type of data everywhere.
OS: Windows XP → All
Hardware: PC → All

Comment 3

16 years ago
Do we know which versions of IE have this problem?  I see the problem on my
system which has IE6 - i.e., the AOL8 on my system shows the problem and uses a
recent version of IE.  However, IE6 standalone does not show the problem.
(Reporter)

Comment 4

16 years ago
If I type in a local file URL to the testcase in AOL8 it displays properly. But
it does not display properly when the same testcase is displayed as a AOL8 mail
message. So it isn't a bug in an earlier version of IE. Probably AOL8 mail specific.

Updated

16 years ago
Blocks: 193019

Comment 5

16 years ago
So I wrote a few test cases and I think I see the source of the inconsistency.

It seems that when the font size isn't specified, the default size in Gecko and
in IE6 matches the size for <font size="3"> ... whereas in AOL mail the  default
size matches <font size="2">.
No longer blocks: 193019

Updated

16 years ago
Blocks: 193020
(Reporter)

Comment 6

16 years ago
Yes, I've confirmed that AOL7/8 assume Arial 10pt is the default font. They do
this by changing the default font and size when viewing mail.  IE and Gecko set
the default to Times Roman 12pt on WIN32. This is the cause of this bug.
(Assignee)

Comment 7

16 years ago
So what's the solution?  How do we know that the source of a paste was AOL8? 
Are we going to ignore font size 2 for all pastes?  
(Assignee)

Comment 8

16 years ago
The more I think about this, the more I agree with Kin.  This really needs to be
fixed in aol8.  They should set the default to 12 and explicitly specify 10pt in
their font tags, which they are outputing anyway.

Comment 9

16 years ago
EDITORBASE+
Whiteboard: EDITORBASE → EDITORBASE+
QA Contact: sujay → sairuh

Comment 10

16 years ago
Discussed in edt. Plussing.
Keywords: topembed → topembed+

Comment 11

16 years ago
I have to confess, I don't understand what problem is being reported in this bug.
What does IE have to do with this?
When I look at the attached testcase with either IE 5 or latest Gecko, all text
is being displayed with the same size on my system.
(Reporter)

Comment 12

15 years ago
Marking invalid based on comment#6. Applications that want to avoid the
inconsistency between AOL8 and Gecko should avoid using UI that produces <BIG>
and  <SMALL> elements.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 13

15 years ago
marking verified since we know the culprit is the forced font size
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.