links cease to work when styled with both :before and :hover selectors

RESOLVED DUPLICATE of bug 188525

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 188525
15 years ago
15 years ago

People

(Reporter: Doug Daniels, Assigned: dbaron)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

Whenever you style a link with both the :before and :hover selectors, it will
cease to work as a link.  When you mouseover it, it displays the link cursor,
but when you click on it nothing happens.

The bug happens no matter which properties you apply with these selectors--in
our test case we apply none at all and it still happens.

This bug only starts happening on Mozilla 1.3b.  1.3a does not display the
behavior.  Additionally, the bug does not happen on the Windows platform, but
does happen on the Linux platform.


Reproducible: Always

Steps to Reproduce:
1. go to above page
2. try to follow the link
3. if you're using Moz 1.3b Linux it won't work
(Assignee)

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 188525 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.