Status

SeaMonkey
General
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: David D. Huff Jr., Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Toolbar fonts are stupidly large.

Reproducible: Always

Steps to Reproduce:
1.compile mozilla 1.3b for linux
2.
3.

Actual Results:  
Stupidly large fonts.

Expected Results:  
Some QA for the release.
Details?  In particular:

1) What DPI are you running yet?
2) Are you using Xinerama or the like?
3) What are the default fonts set to in your GTK theme?

(as a note, I am _not_ seeing this problem in Linux trunk build 2003-02-12-08).
What build options did you use?
And do you see this problem in the released Linux binaries?  (which have been
tested, since you seem to be wondering)
(Reporter)

Comment 4

16 years ago
This was the full source build release 1.3b, 1.3a was ok. This is a source based
distro and I've been building mozilla for the last year.The following canned
script has always worked. The gtk fonts I am using are monospace 12/14.

  export  MOZILLA_OFFICIAL=1
  export  BUILD_OFFICIAL=1

  ./configure  --disable-tests              \
               --disable-debug              \
               --enable-optimize="$CFLAGS"  \
               --with-system-jpeg           \
               --with-system-zlib           \
               --with-system-png            \
               --with-system-mng            \
               --enable-crypto              
(Reporter)

Comment 5

16 years ago
Created attachment 114298 [details]
Picture of working 1.3a build with same configuration.

Almost picture perfect, this is the 1.3a build on the same system with the same
configuration.
(Reporter)

Comment 6

16 years ago
Created attachment 114299 [details]
Wacky application fonts with 1.3b build

I regret that I can't provide a screenshot showing how huge the menus are when
they overlap the whole page.
(Reporter)

Comment 7

16 years ago
Created attachment 114383 [details]
Mozilla fonts build correctly from 2003-01-22

This image was built today on the 2003-01-22 source. I know that the coding
problem with the fonts occurs between the 22 & 26th of January this year
because I retested the source from the 26th yesterday. I was a little put off
that the fonts were still wrong on a release even if it was beta. As to the
version of gtk+ that I am using it is 2.0.9. It is a Gnome system I have
removed all traces of anything that uses QT libraries.

Since this is a source built distro I can tell you the version of anything you
want to know on the system. So if I can help in any way please ask. Thanks!
Are you sure it was a change in that time period.  The changes then were:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=MozillaTinderboxAll&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2003-01-22+00%3A00&maxdate=2003-01-27+00%3A00&cvsroot=%2Fcvsroot

(Might the change have related to, say, which version of GTK you were building
against -- for example, if you installed a new version of GTK or removed an old
version?  Do you have a version of GTK 1.2 installed on your system as well,
because that's what we should use by default.)
(Reporter)

Comment 9

16 years ago
Yes, I missed that, gtk+ version 1.2.10 is installed with 2.0.9.

But, two nights ago I compiled the nightly from 2003-01-26 and got the oversized
fonts. Last night I compiled the 2003-01-22 nightly and got the fonts in the
better looking .png. I had tried a couple times over the last couple of weeks to
compile a nightly that had better looking fonts. When the beta came out I got a
little upset that the release version still had the problem.

So since I'm building binary packages from every compile, I'll compile each of
three successive days until I get the ugly fonts. At least you'll know which day
was the first that created the problem. 
(Reporter)

Comment 10

16 years ago
Some of the earlier versions are no longer available for testing so the only
thing I can say is that the problem came up between the release 1.3a and the
26th of January. If nobody else has reported this problem with the strange
fonts, then it may be unique to my system and the ticket can be closed.

Please let me know if there are any suggestions how to change this.

Comment 11

16 years ago
I have the same problem with the RedHat 7.x rpms for mozilla 1.3b, and I did not
have the problems with 1.3a.
I'm seeing some wacky fonts myself with the distributed RH 7.x RPMs on my dad's
laptop, but the problem doesn't show up in a build I did myself to debug the issue.

Comment 13

16 years ago
I have upgraded to 1.3 (still rpms) and still have the giant font problem.  This
did not occur with my 1.2 or 1.3a rpms.  
(Reporter)

Comment 14

16 years ago
I forgot to update my findings. For me the 1.3 release fixed the problem if I
set the preferences to use system fonts instead of 96 DPI. Secondly I've tried
two of the nightly 1.4a builds and the problem is completely gone. I'm not going
to complain but now changing from 96 DPI to system fonts has no effect. I
thought it was kind of cool to have the utopia font on my toolbar.

Comment 15

16 years ago
Thanks for the update.  For the sake of completeness, I fixed my problem by
doing the opposite -- switching *to* 96 DPI fonts *from* system fonts.

Go figure.

Updated

15 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 16

15 years ago
Geeze, forgot all about that. Later in the day of my last posting I switched
distros from Sorcerer to Gentoo and never had another problem with Mozilla.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.