opening jpeg attachment to email message doesn't update browser window

VERIFIED DUPLICATE of bug 191215

Status

MailNews Core
Attachments
VERIFIED DUPLICATE of bug 191215
15 years ago
9 years ago

People

(Reporter: Marc Jacobsen, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

I am using IMAP (in case this makes a difference).  If I open an email with an
attached jpeg file, the message body and attached jpeg file(s) show up properly
in the message pane.  However, if double click on the *.jpg attachment in the
attachments list (or right click and select "open") it doesn't display the image
in a browser window like it is supposed to.  The browser window has it's URL
field updated to point to the image on the IMAP server, but the displayed page
is not updated.  If I put the focus into the URL field and hit "Enter" then the
image is displayed in the browser.

Reproducible: Always

Steps to Reproduce:
1.  Open an email (on IMAP server?) with attached jpeg
2.  Right click on the jpeg in the little attachments list and select "open"
3.  Notice the URL in your Navigator window change, but the page displayed
doesn't change.
4.  Put the focus in the Navigator URL input field, hit the "enter" key, NOW the
jpeg will be displayed in the Navigator window.

Actual Results:  
The image was only displayed after doing an "enter" keystroke in the URL input
field of Navigator.

Expected Results:  
When I opened the attached JPEG file it should have appeared in the Navigator
window without any further actions needed.

I found the workaround by accident (pressing "Enter" in the URL input field), to
a normal user, opening an image attachment (maybe just jpeg) simply won't work.
 That's why I am entering this as a normal severity, not a minor severity.

*** This bug has been marked as a duplicate of 191215 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.