<HR> display between unlike body parts does not work when "format=flowed" is present

VERIFIED DUPLICATE of bug 18972

Status

MailNews Core
MIME
P3
major
VERIFIED DUPLICATE of bug 18972
18 years ago
10 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: rhp (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
** Observed with 11/18/99 Win32 build **

This bug is related to Bug 18972.

The test file at the above URL contains 2 identical messages except
that the 2nd message does not contain "format=flowed" parameter
in the headers of the 1st body part.
The messages contain a plain text 1st part and an HTML page
attachment in the second part.

When there is "fromat=flowed" within the 1st headers, Mozilla
fails to display the <HR> separator. 4.71 does not have this problem.

Also you won't see this problem if you send such messages from
4.x since they don't seem to insert this extra parameter. Thus,
the problem happens only when this type of message is sent from
Mozilla.
(Reporter)

Comment 1

18 years ago
Created attachment 2950 [details]
Test mailbox file for Bug 19309
(Reporter)

Comment 2

18 years ago
I created an atatchment which contains the 2 test msgs I described
above. The 2nd msg was manually edited to leave out "format=flowed".
The text body says that it has been edited out and you will know
which one it is. In any case the 2nd message shows the <HR>
separator but the 1st one does not.

I made an error in mime type and so it will come up as
"showattachment.cgi". Just save it as ".zip" and unarchive it.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

18 years ago
Well, the reason for this is that text/plain messages that are displayed with
the format=flowed paramter are actually displayed as HTML since HTML text is
flowed...and since this is an HTML display, no horizontal line. So, basically,
this is the same bug as the other one we have been discussing...if I fix that
one ... someday... this one will be fixed as well.

- rhp

*** This bug has been marked as a duplicate of 18972 ***

Updated

18 years ago
QA Contact: lchiang → pmock

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
Verified as duplicate.

I did download this bug attachment and try it out on win32, linux, and macos
using the following builds:
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/1999-12-15-09-M12/sea
monkey32e.exe
ftp://sweetlou/products/client/seamonkey/unix/linux_glibc/2.2/x86/1999-12-15-08-
M12/netscape-i686-pc-linux-gnu.tar.gz
ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/1999-12-15-08-M12/netscap
e5-mac-M12.sea.bin

Viewing the sample mail message looks good.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.