When going to this website (or most any other site using xoops) Phoenix just closes with no warning.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Jeff Stuart, Assigned: Blake Ross)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211 Phoenix/0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211 Phoenix/0.5

Whenever I go to a xoops based website, Phoenix simply closes.  This is Phoenix
CVS as of 2/11/2003.  No clue WHY it shuts down.  If I run phoenix from the
command line, I get no error output.  Note: If I browse the sites using Konqi,
it works fine.

Reproducible: Always

Steps to Reproduce:
1. Go to ANY xoops based website

Actual Results:  
Phoenix shuts down.

Expected Results:  
Displayed the web page. :)
(Reporter)

Comment 1

16 years ago
here's a back trace:  
 
#0  0x00000000 in ?? () 
#1  0x401b03bb in nsQueryInterface::operator()(nsID const&, void**) const () 
   from /usr/lib/phoenix/libxpcom.so 
#2  0x401b0484 in nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID 
const&) 
    () from /usr/lib/phoenix/libxpcom.so 
#3  0x407cb525 in NSGetModule () from /usr/lib/phoenix/components/libxpconnect.so 
#4  0x407b5b23 in NSGetModule () from /usr/lib/phoenix/components/libxpconnect.so 
#5  0x407a9600 in NSGetModule () from /usr/lib/phoenix/components/libxpconnect.so 
#6  0x416d9f9b in NSGetModule () from /usr/lib/phoenix/components/libjsdom.so 
#7  0x416d98bf in NSGetModule () from /usr/lib/phoenix/components/libjsdom.so 
#8  0x407cbe10 in NSGetModule () from /usr/lib/phoenix/components/libxpconnect.so 
#9  0x407cc25c in NSGetModule () from /usr/lib/phoenix/components/libxpconnect.so 
#10 0x407b5b23 in NSGetModule () from /usr/lib/phoenix/components/libxpconnect.so 
#11 0x407a9600 in NSGetModule () from /usr/lib/phoenix/components/libxpconnect.so 
#12 0x416cb63f in NSGetModule () from /usr/lib/phoenix/components/libjsdom.so 
#13 0x416d6f60 in NSGetModule () from /usr/lib/phoenix/components/libjsdom.so 
#14 0x416d7013 in NSGetModule () from /usr/lib/phoenix/components/libjsdom.so 
#15 0x407d5024 in NSGetModule () from /usr/lib/phoenix/components/libxpconnect.so 
#16 0x4007c523 in js_GetProperty () from /usr/lib/phoenix/libmozjs.so 
#17 0x4006c575 in js_Interpret () from /usr/lib/phoenix/libmozjs.so 
#18 0x400665b0 in js_Invoke () from /usr/lib/phoenix/libmozjs.so 
#19 0x407c9698 in NSGetModule () from /usr/lib/phoenix/components/libxpconnect.so 
#20 0x407c580a in NSGetModule () from /usr/lib/phoenix/components/libxpconnect.so 
#21 0x4019062a in nsXPTCStubBase::Stub249() () from /usr/lib/phoenix/libxpcom.so 
#22 0x40af1966 in NSGetModule () from /usr/lib/phoenix/components/libgklayout.so 
#23 0x40af3325 in NSGetModule () from /usr/lib/phoenix/components/libgklayout.so 
#24 0x416abf5c in NSGetModule () from /usr/lib/phoenix/components/libjsdom.so 
#25 0x40c8e501 in NSGetModule () from /usr/lib/phoenix/components/libgklayout.so 
#26 0x40c7291b in NSGetModule () from /usr/lib/phoenix/components/libgklayout.so 
#27 0x40c724ba in NSGetModule () from /usr/lib/phoenix/components/libgklayout.so 
#28 0x40c724ba in NSGetModule () from /usr/lib/phoenix/components/libgklayout.so 
#29 0x40c724ba in NSGetModule () from /usr/lib/phoenix/components/libgklayout.so 
#30 0x40c724ba in NSGetModule () from /usr/lib/phoenix/components/libgklayout.so 
#31 0x40c724ba in NSGetModule () from /usr/lib/phoenix/components/libgklayout.so 
#32 0x40c77ee0 in NSGetModule () from /usr/lib/phoenix/components/libgklayout.so 
#33 0x416abef4 in NSGetModule () from /usr/lib/phoenix/components/libjsdom.so 
#34 0x40d25436 in NSGetModule () from /usr/lib/phoenix/components/libgklayout.so 
#35 0x416764cc in NSGetModule () from /usr/lib/phoenix/components/libdocshell.so 
#36 0x41684b74 in NSGetModule () from /usr/lib/phoenix/components/libdocshell.so 
#37 0x41676144 in NSGetModule () from /usr/lib/phoenix/components/libdocshell.so 
#38 0x4151f05f in NSGetModule () from /usr/lib/phoenix/components/liburiloader.so 
#39 0x4151e415 in NSGetModule () from /usr/lib/phoenix/components/liburiloader.so 
#40 0x4151e2a3 in NSGetModule () from /usr/lib/phoenix/components/liburiloader.so 
#41 0x4151dff9 in NSGetModule () from /usr/lib/phoenix/components/liburiloader.so 
#42 0x4080a599 in NSGetModule () from /usr/lib/phoenix/components/libnecko.so 
#43 0x417ded96 in NSGetModule () from /usr/lib/phoenix/components/libimglib2.so 
#44 0x417dda54 in NSGetModule () from /usr/lib/phoenix/components/libimglib2.so 
#45 0x417dabd2 in NSGetModule () from /usr/lib/phoenix/components/libimglib2.so 
#46 0x40820bc1 in NSGetModule () from /usr/lib/phoenix/components/libnecko.so 
#47 0x40868d57 in NSGetModule () from /usr/lib/phoenix/components/libnecko.so 
#48 0x4080505b in NSGetModule () from /usr/lib/phoenix/components/libnecko.so 
#49 0x40804d0d in NSGetModule () from /usr/lib/phoenix/components/libnecko.so 
#50 0x4015736a in nsInputStreamReadyEvent::EventHandler(PLEvent*) () 
   from /usr/lib/phoenix/libxpcom.so 
#51 0x40171b27 in PL_HandleEvent () from /usr/lib/phoenix/libxpcom.so 
#52 0x40171a04 in PL_ProcessPendingEvents () from /usr/lib/phoenix/libxpcom.so 
#53 0x40172e83 in nsEventQueueImpl::ProcessPendingEvents() () 
   from /usr/lib/phoenix/libxpcom.so 
#54 0x40ef04e5 in NSGetModule () from /usr/lib/phoenix/components/libwidget_gtk.so 
#55 0x40ef005d in NSGetModule () from /usr/lib/phoenix/components/libwidget_gtk.so 
#56 0x403f32d4 in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0 
#57 0x403f4b3e in g_main_dispatch () from /usr/lib/libglib-1.2.so.0 
#58 0x403f500b in g_main_iterate () from /usr/lib/libglib-1.2.so.0 
#59 0x403f521a in g_main_iteration () from /usr/lib/libglib-1.2.so.0 
#60 0x402f7b58 in gtk_main_iteration () from /usr/lib/libgtk-1.2.so.0 
#61 0x4299138e in gtkTimerCallback () from /opt/netscape/plugins/libflashplayer.so 
#62 0x403f5b05 in g_timeout_dispatch () from /usr/lib/libglib-1.2.so.0 
#63 0x403f4b3e in g_main_dispatch () from /usr/lib/libglib-1.2.so.0 
#64 0x403f500b in g_main_iterate () from /usr/lib/libglib-1.2.so.0 
#65 0x403f5294 in g_main_run () from /usr/lib/libglib-1.2.so.0 
#66 0x402f78c7 in gtk_main () from /usr/lib/libgtk-1.2.so.0 
#67 0x40ef0966 in NSGetModule () from /usr/lib/phoenix/components/libwidget_gtk.so 
#68 0x40ed1044 in NSGetModule () from /usr/lib/phoenix/components/libnsappshell.so 
#69 0x0805377f in getCountry(nsAString const&, nsAString&) () 
#70 0x080541be in xre_main(int, char**, nsXREAppData const&) () 
#71 0x0804e71e in main () 
#72 0x4060ae34 in __libc_start_main () from /lib/libc.so.6 
 

Comment 2

16 years ago
WFM using Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3b) Gecko/20030211
Phoenix/0.5

Does this error occur immediately or do you need to surf around on that page a
little bit? Did you already checked with a new profile?

--> added keyword "crash"
Keywords: crash

Comment 3

16 years ago
works with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a)
Gecko/20030106 Phoenix/0.5 - kinda old I know ;)

Comment 4

16 years ago
David, can you confirm this?
Severity: blocker → critical

Comment 5

16 years ago
Jeff - Can you try a recent Mozilla build?

Comment 6

16 years ago
WFM Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211 Phoenix/0.5

That's using the pre-compiled binary and not a CVS build. Do you get this with
the downloaded version as well and, if not, what build options are you using?
Also, how does Mozilla 1.3b or a recent Moz nightly fare on the same site?
(Reporter)

Comment 7

16 years ago
This is a Phoenix CVS build.  I'm using Gentoo and am emerging phoenix-cvs. 
I'll try to grab both the latest build tarball and also grab it via CVS and
compile both without using emerge.  

Nor did I try it with a new profile.  
(Reporter)

Comment 8

16 years ago
HMM... Ok... I recompiled the CVS version of Phoenix and it now works.  There
must be something wrong then with the Gentoo ebuild... :(  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 9

16 years ago
Not fixed, but WFM.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 10

16 years ago
-> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

16 years ago
Ok sorry for the quick It works announcment.  I then built Phoenix later on
today and it failed again.  Note: these sites work PERFECTLY in Phoenix 0.5.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 12

16 years ago
oh and to add on, the profile that is working 0.5 is the same one as I can not
get to work in CVS.

Comment 13

16 years ago
Can you post your build options?
(Reporter)

Comment 14

16 years ago
Here are my env options:

export MOZ_PHOENIX=1
export MOZ_CALENDAR=0
export MOZ_ENABLE_XFT=1

And my config options:
--disable-composer \
--with-x \
--with-system-jpeg \
--with-system-zlib \
--with-system-png \
--with-system-mng \
--with-java-supplement \
--with-pthreads \
--with-default-mozilla-five-home=${PHOENIX_PATH} \
--with-user-appdir=.phoenix \
--without-system-nspr \
--enable-reorder \
--enable-strip \
--enable-strip-libs \
--enable-cpp-rtti \
--enable-xterm-updates \
--enable-xft \
--enable-mathml \
--enable-nspr-autoconf \
--enable-xsl \
--enable-crypto \
--enable-xinerama=no \
--disable-mailnews \
--disable-calendar \
--disable-pedantic \
--disable-jsd \
--disable-accessibility \
--disable-tests \
--disable-debug \
--disable-dtd-debug \
--disable-ldap \
--enable-toolkit-gtk \
--enable-default-toolkit=gtk \
--disable-toolkit-qt \
--disable-toolkit-xlib \
--disable-toolkit-gtk2 \
--disable-svg \
--enable-old-abi-compat-wrappers \
--prefix=/usr

And my CFLAGS/CXXFLAGS: 
CFLAGS="-O2 -march=athlon-xp -pipe -s -fforce-addr"
CXXFLAGS="-O2 -march=athlon-xp -pipe -s -fforce-addr -Wno-deprecated"

Comment 15

16 years ago
wfm : 20030222 cvs

.mozconfig :

export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1
ac_add_options --enable-crypto
ac_add_options --disable-tests
ac_add_options --enable-debug
ac_add_options --disable-mailnews
ac_add_options --disable-composer
ac_add_options --enable-optimize=-O2
ac_add_options --enable-xft

ac_add_options --disable-ldap
#ac_add_options
--enable-extensions=default,-inspector,-irc,-venkman,-content-packs,-help
ac_add_options --enable-plaintext-editor-only

Comment 16

16 years ago
nb -inspector etc on same line as preceding #ac_add_options
WFM with Mozilla/5.0 (Windows NT 5.0; en-US; rv:1.3b) Gecko/20030225 Phoenix/0.5

Jeff, have you tried the precompiled binary? Could this be a problem with your
build-config?
(Reporter)

Comment 18

16 years ago
Using the nightly build from 03/04/2003, all xoops sites work again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.