empty trash -> trash display won't change

RESOLVED DUPLICATE of bug 161999

Status

SeaMonkey
MailNews: Message Display
--
minor
RESOLVED DUPLICATE of bug 161999
15 years ago
14 years ago

People

(Reporter: Sebastian Lisken, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

If you have unread messages in the Trash folder (e.g. your
Junk Filter moves messages there before you read them), the
Trash folder is displayed in bold and has " (x)" appended to
its name, where x is the number of unread messages - just
like any other folder. If you then, while looking at the
contents of some other folder, execute either "File > Empty
Trash" from the menu or right-click the trash and again
choose "Empty Trash", the display is still bold with the
added number. Only when you actually click on the trash to
look inside it is the display updated.

Reproducible: Always

Steps to Reproduce:
See description under "Details".
Actual Results:  
Trash displayed with bold "Trash (x)" caption, even after "Empty Trash".

Expected Results:  
Trash caption should revert to non-bold, number should disappear.
(Reporter)

Comment 1

15 years ago
The problem also applies to any visual indication of a subfolder.
Move a whole folder to the trash, empty trash while looking at
another folder -> the "expand to subfolders" icon (a small triangle
in the Modern theme) is still there.

Updated

15 years ago
Severity: normal → minor

Comment 2

15 years ago
Also happens in 2003021213 OS/2 trunk. OS->All
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 161999 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.