moving bookmarks changes context menu in some cases

RESOLVED DUPLICATE of bug 124600

Status

SeaMonkey
Bookmarks & History
--
minor
RESOLVED DUPLICATE of bug 124600
16 years ago
14 years ago

People

(Reporter: Drew Colthorp, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210

dragging/moving a bookmark in either the bookmark manager or tab makes the
context menu not work when the user right-clicks on white space (not a
bookmark/separator/folder)

Reproducible: Always

Steps to Reproduce:
1. Scroll to then end of your bookmarks
2. Right-click on some blank space (not an entry)
3. Drag a bookmark up or down a position
4. right-click on blank space again

Actual Results:  
The first click yields the context menu, but the second, after dragging, does
not.  If the user right clicks on an entry (folder/separator/bookmark) this does
not happen, and the context menu appears as normal

Expected Results:  
Moving an item should have no affect on context menu behavior

Comment 1

16 years ago
The reason this occurs is because after dropping a bookmark, it unselects it. 
As long as a bookmark is selected, clicking on an empty space will open a
context menu for that item.

Not sure what should be fixed: item deselected after drop, or context menu
appears in empty area.

Comment 2

16 years ago
From an email from the reporter:

"I'd say the behavior to fix is the context-menu on blank space.  Changing the
deselect behavior would fix it, but will the average user understand what's
happening if he right clicks just below a bookmark, hits delete, and the
bookmark at the top of the list is deleted?  Granted, a scenario exactly like
this is unlikely, but possible."

Therefore, this is a duplicate of bug 135813


*** This bug has been marked as a duplicate of 135813 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
oops, wrong dupe
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

15 years ago
QA Contact: kasumi → petersen

Comment 4

14 years ago
it's one of the above mentioned bug or bug 124600

*** This bug has been marked as a duplicate of 124600 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.