mouseOut and mouseOver events not firing properly for image maps

RESOLVED DUPLICATE of bug 110072

Status

()

RESOLVED DUPLICATE of bug 110072
16 years ago
16 years ago

People

(Reporter: monpublic, Assigned: john)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030213
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030213

http://www.bouncingchairs.net/testmzbug2.html showcases this problem:

A div with two images (one hidden) and an image map with multiple areas is
shown.  In Mozilla 1.3a, this page works flawlessly (i.e., the events fire when
moving *within* the image map, as area boundaries are crossed).  In Mozilla 1.3b
and the Feb 13th nightly build, it is broken.  The events appear to only fire
when moving into or out of the *entire map*, instead of in or out of each area,
as it should be.

Reproducible: Always

Steps to Reproduce:
1. Browse to http://www.bouncingchairs.net/testmzbug2.html
2. Move your mouse over the image (it's a single image) without leaving it.
3. No move the mouse into and out of the image area.

Actual Results:  
In Mozilla 1.3b and later (up to current nightly build) only one of the buttons
turns black no matter where the mouse is located.  It stays that way until the
mouse moves completely off of the image.

Expected Results:  
In Mozilla 1.3a the behavior is correct.  When moving the mouse over the image,
each button is highlighted when the mouse is over it.  The events are supposed
to be tied to areas of an image map, not to the entire image.
jkeiser, this is yours.  I seem to recall another UNCO bug on this too... in any
case, your text node changes broke events on <map> elements.
Assignee: saari → jkeiser
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

16 years ago
As it turns out, bug 185889 fixes another image map mouseout/mouseover problem,
so it probably fixes this too.
Depends on: 185889
(Assignee)

Comment 3

16 years ago
This is a dup of bug 110072, and is fixed by the fix for bug 185889, which fixed
that bug.

*** This bug has been marked as a duplicate of 110072 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.