Proxy: Implement NT-based proxy authentication

VERIFIED DUPLICATE of bug 35159

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 35159
16 years ago
16 years ago

People

(Reporter: mcbridematt, Assigned: darin.moz)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; APC)
Build Identifier: All Versions of Mozilla

I need to use NT-based proxy authentication at work.

What we need to do:
1) If we get a 407 (not authenticated) error from the proxy server, 
try again as if we need to do a HTTP 300 (except were not asked to).
2) On Win32, add a NT Domain field in the authentication dialog

Reproducible: Always

Steps to Reproduce:
You need a WinNT or Win2000 based proxy to do this:
1) Set mozilla to use the NT/2000 based proxy
2) Try to go to any page outside the local network

Actual Results:  
I got a HTTP 407 error

Expected Results:  
Authenticated with NT-user details

*** This bug has been marked as a duplicate of 35159 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
VERIFIED/DUPE:
please search for duplicates before filing a bug. If you did so, let me know
what you looked for so I can improve the hit rate on the existing bug.
Status: RESOLVED → VERIFIED
Component: Networking: HTTP → Networking
QA Contact: httpqa → benc
Summary: Implement NT-based proxy authentication → Proxy: Implement NT-based proxy authentication
You need to log in before you can comment on or make changes to this bug.