RFE: Start with last PAGE SET visited

RESOLVED DUPLICATE of bug 36810

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 36810
15 years ago
13 years ago

People

(Reporter: Deian Chepishev, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210

Currently Navigator has option to display the last page visited on startup.
One of the main reasons for me to still use Opera is that if it crashes or if I
close the browser, the next browsing session I can continue from where I left
it, this way I have a 'temporary multipage bookmark'.

Currently Mozilla has a plugin to handle the crash scenario (Total Recall), but
I'd like to have the "remember my pageset" as well.

It would work like this, on each page opened and on shutdown mozila should remember:
- the position of every tab/window
- the last opened URL of every tab window (this would work nice with caching the
currently opened pages, so I can read some long documents offline)
- the scroll position in the document
- the active window/tab

Reproducible: Always

Steps to Reproduce:
1. Open preferences > Navigator
2. Check "When Navigator starts display last page visited"
3. Open two pages (e.g. in two tabs of the same window)
4. Restart the browser

Actual Results:  
I see the last page only

Expected Results:  
I should see the browser as I left it

I envision the UI for this functionality as additional radiobutton in "When
Navigator starts" group. It could read something like: "restore full browser state"

Comment 1

15 years ago
dup of bug 36810?

Comment 2

15 years ago
Yes.

*** This bug has been marked as a duplicate of 36810 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.