Offline: HomePage conflicts with 'Work Offline' checkbox




15 years ago
9 years ago


(Reporter: Bjarne D Mathiesen, Assigned: asa)


Mac OS X

Firefox Tracking Flags

(Not tracked)




15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; da-DK; rv:1.3b; MultiZilla v1.1.33 (a)) Gecko/20030213
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; da-DK; rv:1.3b; MultiZilla v1.1.33 (a)) Gecko/20030213

If you have set Navigator to start up with a home page, and then upon startup
select 'Work Offline' in the profile selector dialogue, you get a warning
dialogue saying that this page cannot be displayed while working offline.

Problem is,
1) the 'OK' button doesn't work, so you can't dismiss it
2) the dialogue seems to be drawn before the browser window

Reproducible: Always

Steps to Reproduce:
1. set mozilla up to open a new navigator window displaying a home page at startup
2. you need to have at least 2 profiles
3. in the dialogue box for selecting a profile upon startup, check 'Work Offline'
4. start Mozilla proper

Actual Results:  
1) no navigator window is displayed
2) it's impossible to dismiss the warning dialogue
3) it's impossible to open any navigator window at all
4) all other component from the window menu are available and working
5) none of the other mozilla components are able to open an URL in navigator
6) only way to get navigator back is to restart mozilla

Expected Results:  
1) dismissed the dialogue box upon clicking the 'OK' button
2) checked for an old version of the home page in the cache and displayed that

Comment 1

15 years ago
WFM using 1.3b (2003021008) on Windows 2000 - it loaded the cached version
without any complaints.

Mac only? Related to MultiZilla?

Comment 2

15 years ago
can I get perodic bug checks even if I know NOT of a bug on my PC? & is so, 
How? thank you

Comment 3

14 years ago
Bjarn, is this still a problem?

Comment 4

14 years ago
wfm with 1.6 release - but now we'we got bug 229763
sorry about not keeping up with my reported bugs :-(
Last Resolved: 14 years ago
Resolution: --- → FIXED


14 years ago
Resolution: FIXED → ---


14 years ago
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME

Comment 5

14 years ago
REOPEN: this is still a problem
Component: Browser-General → Networking
QA Contact: asa → benc
Resolution: WORKSFORME → ---
Summary: Navigator startup with HomePage conflicts with 'Work Offline' startup → Offline: HomePage conflicts with 'Work Offline' checkbox

Comment 6

14 years ago
You need to empty cache before trying to replicate the problem, otherwise
Mozilla will may your homepage out of cache.

If you look under the Window menu, there is "Window" and "Alert" at the very
bottom. Choose "Alert", then press Return on your keyboard.

The steps to replicate the problem are:
1. Run Mozilla
2. Click Mozilla > Preferences > Advanced > Cache
3. Click Empty Cache
4. Click OK to clear the Preferences window
5. Click File > Work Offline
6. Quit Mozilla
7. Launch Mozilla

The problem seems to be that a blocking alert (sheet?) is appearing, but may be
attached to the ".hidden" window, instead of being displayed after a new window
is opened.

When you choose Window > Alert and press return, you bring the hidden alert
forwards, then clear it. Mozilla then progresses as it should.

And, yes it is still a problem, in Mozilla 1.7.

Comment 7

14 years ago
much more confusing:

I edited my /chrome/browser.jar::/content/browser/browser.xul and removed the
"Work Offline" item within the "File" Menu.
Homepage was set to "about:blank"

after starting firefox, the url bar is unusable.
setting the homepage to something like "", the url bar is

Reproducable: Always!

ps: may it is a own bug?

System: SuSE Linux (9.0), 2.4 kernel
Browser: Firefox PR (0.10), xft+gtk2, clean installation
We have an error page now. No dialog does come up anymore. WFM with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090427 Shiretoko/3.5b5pre ID:20090427031112
Last Resolved: 14 years ago9 years ago
Hardware: PowerPC → All
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.