Installer fails to install, exits with error message

RESOLVED WORKSFORME

Status

Core Graveyard
Installer: XPInstall Engine
--
blocker
RESOLVED WORKSFORME
15 years ago
2 years ago

People

(Reporter: c s, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823 Netscape/7.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Mozilla1.3b

after updating pam .rpms yesterday from RedHat8.0 up2date (unrelated???)
Mozilla-mail would not start (Mozilla-1.3.a). A an automated bug send popped up.
I repeaded this one more time. Then I downloaded the 1.3b and tried to install
it. No go.
The older 1.3a did not want to play either.
I get things like ./mozilla-installer-bin: relocation error:
/tmp/xpi.6Bxnb3/bin/libxpistub.so: undefined symbol:
CreateInstance__18nsComponentManagerRC4nsIDP11nsISupportsRC4nsIDPPv


Reproducible: Always

Steps to Reproduce:
1  .download the 1.3b, untar etc.
2. # ./mozilla-installer-bin
3.  behold the **** out install

Actual Results:  
exit with error message

Expected Results:  
installed like a charm, as usual

[root@w4 mozilla-installer_1.3b]# ./mozilla-installer-bin
./mozilla-installer-bin: relocation error: /tmp/xpi.icRJnN/bin/libxpistub.so:
undefined symbol:
CreateInstance__18nsComponentManagerRC4nsIDP11nsISupportsRC4nsIDPPv
[root@w4 mozilla-installer_1.3b]# ./mozilla-installer-bin
./mozilla-installer-bin: relocation error: /tmp/xpi.0ne3Q4/bin/libxpistub.so:
undefined symbol:
CreateInstance__18nsComponentManagerRC4nsIDP11nsISupportsRC4nsIDPPv

[root@w4 mozilla-installer_1.3b]# ./mozilla-installer-bin
./mozilla-installer-bin: relocation error: /tmp/xpi.8ldCK8/bin/libxpistub.so:
undefined symbol:
CreateInstance__18nsComponentManagerRC4nsIDP11nsISupportsRC4nsIDPPv
(Reporter)

Comment 1

15 years ago
Created attachment 114570 [details]
desktop snapshot of crash of mozilla-mail trying to open, behold the memory use
Wait.  Are you using the _Mozilla_ installer to install on top of an _RPM_ install?
(Reporter)

Comment 3

15 years ago
[root@w4 root]# rpm -q mozilla
mozilla-1.2-0_rh8_xft
[root@w4 root]# rpm -e mozilla-1.2-0_rh8_xft
error: Failed dependencies:
        libgkgfx.so is needed by (installed) mozilla-dom-inspector-1.2-0_rh8_xft
        libmozjs.so is needed by (installed) mozilla-mail-1.2-0_rh8_xft
        libmozjs.so is needed by (installed) mozilla-psm-1.2-0_rh8_xft
        libxpcom.so is needed by (installed) mozilla-mail-1.2-0_rh8_xft
        libxpcom.so is needed by (installed) mozilla-dom-inspector-1.2-0_rh8_xft
        libxpcom.so is needed by (installed) mozilla-psm-1.2-0_rh8_xft
        mozilla is needed by (installed) plugger-4.0-17
        mozilla = 1.2-0_rh8_xft is needed by (installed) mozilla-mail-1.2-0_rh8_xft
        mozilla = 1.2-0_rh8_xft is needed by (installed)
mozilla-dom-inspector-1.2-0_rh8_xft
        mozilla = 1.2-0_rh8_xft is needed by (installed) mozilla-psm-1.2-0_rh8_xft
        mozilla = 1.2-0_rh8_xft is needed by (installed) mozilla-chat-1.2-0_rh8_xft
        mozilla = 1.2-0_rh8_xft is needed by (installed)
mozilla-js-debugger-1.2-0_rh8_xft
[root@w4 root]#
That does not answer my question.  All that shows is you incorrectly
uninstalling the Mozilla package...
(Reporter)

Comment 5

15 years ago
[root@w4 root]# rpm -e mozilla-1.2-0_rh8_xft --nodeps
[root@w4 root]# rpm -q mozilla
package mozilla is not installed
[root@w4 root]#
... then trying to install # ./mozilla-installer-bin I get an error message:

 when halting at extracting libplc.so
FATAL ERROR [-618] Couldn't open xpistub library
> rpm -e mozilla-1.2-0_rh8_xft --nodeps

That seems like a really bad idea to me since it does not properly uninstall
things either (it leaves all the other packages there, and then the installer
collides with them when it tries to install).

Why not uninstall mozilla1.2.1 properly before trying to install something newer?
(Reporter)

Comment 7

15 years ago
well, this was not a problem with earlier mozilla, when as I can recall the .rpm
based mozilla would not uninstall w/o unresoleved dependencies. Then to use
mozilla I did not invoke the "regular" mozilla but '/usr/local/mozilla/mozilla'
from my desktop shortcut.
(Reporter)

Comment 8

15 years ago
[root@w4 mozilla_rpm]# rm -f /var/lib/rpm/__db.00*
[root@w4 mozilla_rpm]# rpm --rebuilddb
[root@w4 mozilla_rpm]# rpm -e mozilla-1.2-0_rh8_xft.i386.rpm
error: package mozilla-1.2-0_rh8_xft.i386.rpm is not installed
[root@w4 mozilla_rpm]# rpm -Uvh mozilla-1.2-0_rh8_xft.i386.rpm
Preparing...                ########################################### [100%]
        package mozilla-1.2-0_rh8_xft is already installed
[root@w4 mozilla_rpm]# rpm -ivh mozilla-*.rpm
Preparing...                ########################################### [100%]
        package mozilla-nspr-1.2-0_rh8_xft is already installed
        package mozilla-1.2-0_rh8_xft is already installed
        package mozilla-nss-1.2-0_rh8_xft is already installed
        package mozilla-chat-1.2-0_rh8_xft is already installed
        package mozilla-dom-inspector-1.2-0_rh8_xft is already installed
        package mozilla-js-debugger-1.2-0_rh8_xft is already installed
        package mozilla-nspr-devel-1.2-0_rh8_xft is already installed
        package mozilla-nss-devel-1.2-0_rh8_xft is already installed
        package mozilla-psm-1.2-0_rh8_xft is already installed
[root@w4 mozilla_rpm]# rpm -e mozilla-*.rpm
error: package mozilla-1.2-0_rh8_xft.i386.rpm is not installed
error: package mozilla-chat-1.2-0_rh8_xft.i386.rpm is not installed
error: package mozilla-devel-1.2-0_rh8_xft.i386.rpm is not installed
error: package mozilla-dom-inspector-1.2-0_rh8_xft.i386.rpm is not installed
error: package mozilla-js-debugger-1.2-0_rh8_xft.i386.rpm is not installed
error: package mozilla-mail-1.2-0_rh8_xft.i386.rpm is not installed
error: package mozilla-nspr-1.2-0_rh8_xft.i386.rpm is not installed
error: package mozilla-nspr-devel-1.2-0_rh8_xft.i386.rpm is not installed
error: package mozilla-nss-1.2-0_rh8_xft.i386.rpm is not installed
error: package mozilla-nss-devel-1.2-0_rh8_xft.i386.rpm is not installed
error: package mozilla-psm-1.2-0_rh8_xft.i386.rpm is not installed
[root@w4 mozilla_rpm]#
> error: package mozilla-1.2-0_rh8_xft.i386.rpm is not installed

The package is named "mozilla-1.2-0_rh8_xft", not "mozilla-1.2-0_rh8_xft.i386.rpm".

rpm kinda sucks like that.
(Reporter)

Comment 10

15 years ago
OK
I reinstalled mozilla-1.2 for RH, now I'll see if I can get a clean uninstall
(Reporter)

Comment 11

15 years ago
I got all the Mozilla moduls and dependencies OUT, including Plugger and Evolution:

Again same thing: extracting libplc4.so
ERROR ! [-618]   
Fatal eror, could not open xpistub library




[root@w4 mozilla_rpm]# rpm -q mozilla-psm-1.2-0_rh8_xft
mozilla-nss-1.2-0_rh8_xft mozilla-nspr-devel-1.2-0_rh8_xft
mozilla-nspr-1.2-0_rh8_xft mozilla-mail-1.2-0_rh8_xft
mozilla-js-debugger-1.2-0_rh8_xft  mozilla-dom-inspector-1.2-0_rh8_xft 
mozilla-devel-1.2-0_rh8_xft mozilla-chat-1.2-0_rh8_xft  mozilla-1.2-0_rh8_xft
package mozilla-psm-1.2-0_rh8_xft is not installed
package mozilla-nss-1.2-0_rh8_xft is not installed
package mozilla-nspr-devel-1.2-0_rh8_xft is not installed
package mozilla-nspr-1.2-0_rh8_xft is not installed
package mozilla-mail-1.2-0_rh8_xft is not installed
package mozilla-js-debugger-1.2-0_rh8_xft is not installed
package mozilla-dom-inspector-1.2-0_rh8_xft is not installed
package mozilla-devel-1.2-0_rh8_xft is not installed
package mozilla-chat-1.2-0_rh8_xft is not installed
package mozilla-1.2-0_rh8_xft is not installed
[root@w4 mozilla_rpm]#
(Reporter)

Comment 12

15 years ago
I could manually extract ALL packages in ... /xpi to ... /xpi/bin and run
./mozilla from there, all things I tried seemed to work Ok. I used a new profile
for this experiment.
(Reporter)

Comment 13

15 years ago
...including  libplc4.so....

Comment 14

15 years ago
[root@w4 mozilla-installer_1.3b]# ./mozilla-installer-bin

don't do that.  run ./mozilla-installer.  it's a script that runs
mozilla-installer-bin.

Comment 15

15 years ago
Can not reproduce at this future date.  Using build ID: 2003090305

Reporter please download a recent nightly build from
<http://ftp.mozilla.org/pub/mozilla/nightly/latest/>, and then let us know if
you are still experiencing this problem?

Also, please install using ./mozilla-installer script instead of
./mozilla-installer-bin.  This script sets up your environment before running
./mozilla-installer-bin.

Comment 16

15 years ago
Marking this bug as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.