"The connection was refused when attempting to contact AnyWebSite"

RESOLVED INVALID

Status

()

Core
Networking: HTTP
--
major
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Thomas Brad Lewin, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210

Browser works fine when I reinstall the stable Mozilla 1.2.1 release but each 
time I try to install Mozilla 1.3beta I encounter this same problem of not 
being able to reach any websites.  I've tried tweaking my preferences to fix 
but nothing seems to work.

Reproducible: Always

Steps to Reproduce:
1. Install 1.3beta (custom install with no chatzilla or newsgroups)
2. Type any URL
3.



Expected Results:  
connection refused when attempting to contact...

My computer has an Insight cable ISP with a NetGear router.  OS is XP-Pro.  
May be something that changed in the configuration of Mozilla from 1.2 to 
1.3beta which I need to update a setting for but if so I can't find it.
Do you use a firewall like Zone Alarm ?
Summary: "The connection was refused when attempting to contact AnyWebSite" → "The connection was refused when attempting to contact AnyWebSite"
(Reporter)

Comment 2

15 years ago
No firewall like ZoneAlarm running.  The router has a basic NAT firewall but 
it doesn't seem to affect Mozilla 1.2 or Internet Explorer 6.  I also checked 
the router settings and I didn't notice anything that should cause a problem 
but again it's possible I could be missing something.  The strange thing is I 
can install Mozilla 1.2 and browse freely then close out and install Mozilla 
1.3beta and get all connection refuses then install Mozilla 1.2 and everything 
works again all in the same session without opening/closing anything else.
Have you installed a firewall someday on your system ?
It's possible that an old installation can cause this.
BTW: NAT is for the browser invisible..

Please run 1.3b and while 1.3b is running open a cmd window and type :
"netstat -n"

Do you see 2 loopback connections like this ? :
  Proto  Lokale Adresse         Remoteadresse          Status
  TCP    127.0.0.1:3869         127.0.0.1:3870         HERGESTELLT
  TCP    127.0.0.1:3870         127.0.0.1:3869         HERGESTELLT

(The status is in german in my case)
Assignee: asa → darin
Component: Browser-General → Networking: HTTP
QA Contact: asa → httpqa
(Reporter)

Comment 4

15 years ago
Yeah, I got the loopback connections like that.  I uninstalled an old firewall 
program I used to use and sure enough that was the cause and everything works 
fine now.  Thanks for the help Matti.

Comment 5

15 years ago
resolving as Invalid per comment 4.
URL: all
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.