Attempt to access Web Crossing Chat Java Applet instantly crashes Mozilla

RESOLVED EXPIRED

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED EXPIRED
15 years ago
7 years ago

People

(Reporter: pjb, Assigned: Joshua Xia)

Tracking

({crash})

Trunk
x86
Windows 98
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030214
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030214

I step through various pages of the site until I get to the chat java applet.
The instant I click on the "Open chat" button Mozilla crashes. It has never
handled this applet well, causing the browser to do strange things, but now it
crashes completely. The applet works perfectly in Internet Explorer.

Reproducible: Always

Steps to Reproduce:
1.Open main URL
2.Log in
3.Go to chat button
4. Click chat

Actual Results:  
Total crash.

Expected Results:  
Opened the chat window.

Updated

15 years ago
Keywords: crash

Comment 1

15 years ago
what Java plug-in version are you using ? any URL to test ?
Do you still crash after upgrading to Sun's JRE 1.4.1_01 ?
Assignee: asa → joshua.xia
Component: Browser-General → OJI
QA Contact: asa → petersen

Comment 2

15 years ago
got e-mail from reporter :"I did have Sun's JRE 1.4.1_01. Trouble was, I think,
there were too many bits and pieces of earlier versions on my 
machine. So I rooted out all identifiable files and folders that 
looked like they had anything to do with Java, downloaded a 
fresh copy of JRE 1.4.1_01 and now it runs fine.  But why was 
IE running fine where Mozilla was crashing?  Anyway, bug 
fixed."

Marking WFM as per reporter comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
verified wfm based upon comment 2
Status: RESOLVED → VERIFIED

Comment 4

15 years ago
reopening via reporter e-mail:
"OK, here's what happens.

go to Yahoo.

go to Chat

login or register

click on any chatroom. I tried Recreation & Sports>Sailing

Big message comes up saying chat applet is loading
Recreation
Zap! Mozilla crashes totally.  Not even time to fire off a 
feedback.

But Internet Explorer works just fine."

Please comment within bug report, do not reply to bugzilla e-mails.
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

15 years ago
wfm, win2k sp3, 2003021408, jdk 1.4.1_01
(Reporter)

Comment 6

15 years ago
The bug seems to have evaporated. Removal of all Java from the computer and
replacement with a newly downloaded latest version seems to have fixed it.  The
browser now does not crash when the chat applet loads. However, the chat room
features in Mozilla seem to fall short of the features available in Internet
Explorer.  I need to look at this some more.
(Assignee)

Comment 7

15 years ago
I used Mozilla 1.3b
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/2002122
+
jre 1.4.1_01 on Windows 2K
to test.

no crash happened. After I login to chatroom, the room display but soon back to
"Enter Chat Room" page.
(Reporter)

Comment 8

15 years ago
The bug is not fixed. Attempting this morning to get into Yahoo chat rooms, the
window opens with "Chat Applet Loading" then Mozilla promptly crashes.  It's not
just the Web Crossing Java Applet.
(Reporter)

Comment 9

15 years ago
I installed the latest build (2003021704) but the problem remains.  Instant
crash after chat appplet loads.

The problem does NOT exist in Netscape 7.0.
Using Mozilla build 2003021608, JRE version 1.3.0_01 on WinXP, I see no crash.

Comment 11

14 years ago
WFM.

Logged in and entered a chat-room without problems. The JAVA 2 Platform Standard
Edition in the tray shows "Version 1.4.2_03 (build 1.4.2_03-b02)".

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040330
Microsoft Windows 2000 Pro 5.00.2195 SP4
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago13 years ago
Resolution: --- → EXPIRED

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.